Do Not Sell My Personal Information Jump to content


Check Engine Light


MarcInJapan
 Share

Recommended Posts

Just my luck, 2 days owning the car and the check engine light comes on. It was after I detailed the motor, so don't know if that had anything to do with it. I didn't spray it with water or anything like that, just cleaned the hoses and metal. The car seems to run fine with no issues. I left the Battery disconnected overnight to clear the memory, but after the second start up, it came back on again. Maybe a bad oxygen sensor or something like that? I wish I know how to code it like I did my mustang. So many beeps or light flickers on the dash, and I would know what sensor was bad. I guess I will have to take it to the dealer where they will charge me a arm and a leg just to hook it up to a diagnostic machine.

Any suggestions of what it might be? Again the car runs great. The light is annoying as hell and I don't want to drive it too much just in case it might be something serious.

Link to comment
Share on other sites


I would bet for a dead lambda sensor if you still have the cats on the exhaust. You should have the error code read via the OBD II to be sure, any garage has a reader.

Link to comment
Share on other sites



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership