Do Not Sell My Personal Information Jump to content


New Guy Sayin' Hi!


Vince W
 Share

Recommended Posts

Hi everyone, newbie here and immediately needing your help, sorry.

I have an LS400 (1990) that needed a new temp gauge sender. I bought one and started fitting it this morning.

Long story short, it snapped off while I was trying to unscrew it, tried various attempts to remove what was left in the engine using various stud extractors, easy outs etc, now I've gone and split the water bridge that the sender screws into, D'OH! :tsktsk:

So I'm now looking for a replacement water bridge, anyone on here got one???

Thanks awfully, Vince. :blush:

Link to comment
Share on other sites




p.s. Does everyone drive an I.S. on here, or are they just very friendly compared to other Lexus drivers?

Welcome. Not sure, but my impression is that most of the members who are very active on here are IS owners. Definitely should help by posting LS questions in the LS forum there, since there are of course some active LS owners too.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership