Do Not Sell My Personal Information Jump to content


Check Engine Light


JAMY
 Share

Recommended Posts

Hi Guys,

I have a 2001 IS300. I parked it for 6 months without a Battery and when i decided to start using it again the Check engine light came ON. I did minor service of oil filters and air filter but still light ON. So i removed Battery terminal for 15 mins and put them back on and light went OFF. But when i cruise at 80Kph the light comes on AGAIN. What the hell is wrong with her?

Link to comment
Share on other sites


You need to connect up an OBDII reader and get the codes off it. If you post the codes up, then folks here can try and help work out what it might mean. Could be almost anything.

Most garages should be able to help you with it if you haven't got a reader. Although bear in mind they might charge you to help, and the readers are very cheap off eBay !

Link to comment
Share on other sites


Hi Guys,

I have a 2001 IS300. I parked it for 6 months without a battery and when i decided to start using it again the Check engine light came ON. I did minor service of oil filters and air filter but still light ON. So i removed battery terminal for 15 mins and put them back on and light went OFF. But when i cruise at 80Kph the light comes on AGAIN. What the hell is wrong with her?

Did you do the spark plugs?

Link to comment
Share on other sites

Hi Guys,

I have a 2001 IS300. I parked it for 6 months without a battery and when i decided to start using it again the Check engine light came ON. I did minor service of oil filters and air filter but still light ON. So i removed battery terminal for 15 mins and put them back on and light went OFF. But when i cruise at 80Kph the light comes on AGAIN. What the hell is wrong with her?

Did you do the spark plugs?

No i didnt do the spark plugs......But i did the spark plugs 2 months before i parked the car.

Link to comment
Share on other sites


Hi Guys,

I have a 2001 IS300. I parked it for 6 months without a battery and when i decided to start using it again the Check engine light came ON. I did minor service of oil filters and air filter but still light ON. So i removed battery terminal for 15 mins and put them back on and light went OFF. But when i cruise at 80Kph the light comes on AGAIN. What the hell is wrong with her?

Did you do the spark plugs?

No i didnt do the spark plugs......But i did the spark plugs 2 months before i parked the car.

It's not what I was thinking then as you'd of noticed the light after you changed the plugs not just now, best getting the faults codes like Stevie and Chris said then matey.

Does it only come on at 80kph or did it come on when you hit that speed and stay on?

Link to comment
Share on other sites

Hi Guys,

I have a 2001 IS300. I parked it for 6 months without a battery and when i decided to start using it again the Check engine light came ON. I did minor service of oil filters and air filter but still light ON. So i removed battery terminal for 15 mins and put them back on and light went OFF. But when i cruise at 80Kph the light comes on AGAIN. What the hell is wrong with her?

Did you do the spark plugs?

No i didnt do the spark plugs......But i did the spark plugs 2 months before i parked the car.

It's not what I was thinking then as you'd of noticed the light after you changed the plugs not just now, best getting the faults codes like Stevie and Chris said then matey.

Does it only come on at 80kph or did it come on when you hit that speed and stay on?

When i hit the speed it stays ON until i remove the Battery terminals for 15 mins. Is it advisable to drive the car with light ON for a week or two as my mechanics Diagnosis equipment is gone for service...Is OBD11 a Diagnostic equipment?

Link to comment
Share on other sites

Hi Guys,

I have a 2001 IS300. I parked it for 6 months without a battery and when i decided to start using it again the Check engine light came ON. I did minor service of oil filters and air filter but still light ON. So i removed battery terminal for 15 mins and put them back on and light went OFF. But when i cruise at 80Kph the light comes on AGAIN. What the hell is wrong with her?

Did you do the spark plugs?

No i didnt do the spark plugs......But i did the spark plugs 2 months before i parked the car.

It's not what I was thinking then as you'd of noticed the light after you changed the plugs not just now, best getting the faults codes like Stevie and Chris said then matey.

Does it only come on at 80kph or did it come on when you hit that speed and stay on?

When i hit the speed it stays ON until i remove the Battery terminals for 15 mins. Is it advisable to drive the car with light ON for a week or two as my mechanics Diagnosis equipment is gone for service...Is OBD11 a Diagnostic equipment?

Hard to say if it's safe or not without knowing whats wrong with it, if it's only happening when you hit a certain speed then it may be something to do with the amount of air going into the engine, have you made sure you air filter is secure.

Probably be best to get in on a reader a.s.a.p to be honest matey.

Instead of removing the Battery terminals every time you can re-set the ECU by Lifting the bonnet, take the cover off the fuses, take out the 20/25amp EFI and 15A ETCS fuses for 30 seconds to a minute then replace. MAKE SURE THE IGNITION IS OFF. Best thing to do is put the keys in your pocket then do it that's what I do.

Link to comment
Share on other sites

When i hit the speed it stays ON until i remove the battery terminals for 15 mins. Is it advisable to drive the car with light ON for a week or two as my mechanics Diagnosis equipment is gone for service...Is OBD11 a Diagnostic equipment?

Hard to say without knowing what the exact fault is, but the light is a sign that something is probably wrong.

OBDII is a standard for diagnostic equipment, yes. Basically all cars built after a certain date have a connector/interface that complies to this standard, so you can buy a reader, connect it up and read off the codes. You can get standalone readers for around £30, or even cheaper if you already have a laptop that you can use (you can get a special cable for the laptop, then download free software).

A reader may well be cheaper than a trip to the garage !

Link to comment
Share on other sites

as said above really. could just be as simple as a dodgy Lambda sensor (in the exhaust) or iffy MAF/MAP (mass air flow) sensor. does it go into a limp mode at all?

WHATS A LIMP MODE?

Guys,

I have to hand it out to you guys. When i removed the ECU and EFI fuses for a minute baaaaam the light went missing. I havent tested the car properly but i should say it has worked for now. Fingers crossed it will not come back again.

Thanks AndyR

Thanks mates

Link to comment
Share on other sites

Is it definitely at a set speed it always came on or specific revs?

Reason I ask, I had problem where engine light would come on at 4800 revs and hard throttle - Using my ODBII reader it came back as a VSV (Vacuum Switching Valve) for the ACIS (Acounstic Control Induction System) - All sounds very fancy but basically the valve lengthens/shortens the effective length of your manifold to aid efficiency.

Kicks in at 4800 revs and 60% throttle

Not sure if IS has similar installed but you really should should invest in a reader (they are very cheap) or drop off at a garage and get the code read if it happens again.....theres hundreds of reasons why it can come on and you will not normally guess...

Link to comment
Share on other sites

Is it definitely at a set speed it always came on or specific revs?

Reason I ask, I had problem where engine light would come on at 4800 revs and hard throttle - Using my ODBII reader it came back as a VSV (Vacuum Switching Valve) for the ACIS (Acounstic Control Induction System) - All sounds very fancy but basically the valve lengthens/shortens the effective length of your manifold to aid efficiency.

Kicks in at 4800 revs and 60% throttle

Not sure if IS has similar installed but you really should should invest in a reader (they are very cheap) or drop off at a garage and get the code read if it happens again.....theres hundreds of reasons why it can come on and you will not normally guess...

Guys,

I rev'd the car as high as i could and i also drove it as fast as i could and still there was no sign of the Engine check light coming on again. But i will take your advice and i will have the car diagnosed for faults just to be on the safe side.

Otherwise all is well and the car runs smooth....hope it stays that way :unsure:

Link to comment
Share on other sites

Good luck....by the way...as you reset the ECU the way you did it will have also reset the memory and no faults will remain for anyone to diagnose.....hopefully no more probs but if you do have any in the future, get them read before you reset.....otherwise you'll pay for nothing :whistling:

Link to comment
Share on other sites

Good luck....by the way...as you reset the ECU the way you did it will have also reset the memory and no faults will remain for anyone to diagnose.....hopefully no more probs but if you do have any in the future, get them read before you reset.....otherwise you'll pay for nothing :whistling:

Surely if your re-setting the ECU it doesn't matter which way you do it either by fuses or Battery the results will be the same :huh:

I'd still defo get it checked tho matey.

Link to comment
Share on other sites

There is also the "proper" way using a reader where you would read the codes prior to resetting.

No point now the ecu has been cleared and a garage would be non the wiser and have to check everything

Link to comment
Share on other sites

Go to garage (or buy yourself a reader) and get the codes read - Dont reset the ECU again beforehand though

Guys,

I went to the garage and this is the error code i got: P0161 02Sensor Heater Circuit Malfunction(Bank#2 Sensor#2. Whats that? How can i solve it? Can i do it myself.......?

Link to comment
Share on other sites

needs a new post cat o2 sensor...beware as dealers charge a small fortune for so try and source a generic or one from elsewhere.

Fitting I'll leave to my is counterparts to comment on but guess you really need the car raised.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership