Do Not Sell My Personal Information Jump to content


Recommended Posts

A little while back my front screen was replaced by Autoglass after a crack appeared.

I watched the fitter finishing off the job and saw him testing the rain sensor by spraying it with water, all seemed good.

Unfortunately during my journey the following day the wipers operated perhaps every 10 seconds with the control in the auto position, even though it was completely dry.

When I got home I cleaned the sensor thoroughly but the problem persisted.

Took it to the local Autoglass place and they were very helpful, tried a few things and seemed to have it working (lots of spraying of water and further cleaning of the sensor.)

However the problem soon re-surfaced with the wipers never returning to the ''park'' position and in fact when it did rain they failed to speed up at all even when changing the sensitivity setting on the control.

Went back to Autoglass who now had a theory that the tinted strip along the top of the screen might be the problem.

It was revealed that the screen they had put in was not a Lexus replacement one and that the tinted strip was darker than on the original.

A fitter came out and put in a screen they sourced from Lexus (apparently at a cost of over £500.....) and hey presto normal wiper operation was restored.

To be fair Autoglass customer service was top notch but something to keep in mind if they are replacing the screen on your car.

Link to comment
Share on other sites


EXACTLY the same thing happened to me 2 weeks ago and I was wondering what to do.

At the time I asked Autoglass to assure me that this was the EXACT same screen they were replacing and they told me it was...

I shall be calling them first thing Monday!

Thanks for this great post SteveW37!

PS FYI a new sensor is £175 from Lexus! :o

Link to comment
Share on other sites


EXACTLY the same thing happened to me 2 weeks ago and I was wondering what to do.

At the time I asked Autoglass to assure me that this was the EXACT same screen they were replacing and they told me it was...

I shall be calling them first thing Monday!

Thanks for this great post SteveW37!

PS FYI a new sensor is £175 from Lexus! :o

Tyger if it helps at all it was Autoglass in Bracknell that I dealt with.

They should remember it pretty well I reckon.

Link to comment
Share on other sites

Great thread, thanks. I have a chip on my windscreen that could develop in to a crack, and I am dreading getting the new windscreen as I am sure that there would be issues with sensors etc...

I am fairly screwed, cause in Ireland, autoglass have not got the same reputation! Damn. My insurance will only do the 'free replacement' if it's done by Autoglass. So if I want it to be done by Lexus, I'll have to pay for it myself...

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership