Do Not Sell My Personal Information Jump to content


Recommended Posts

Hi got a 2005 GS.

The sunroof opens and closes, but not as it should.

Basically any button will slide the roof back as well as tilt it, and it doesn't have the one touch open close facility.

The manual suggests that if the Battery has been disconnected then it maybe nessecary to carry out a reset. Tried this,,no joy.

Any other ideas before I drop by Mr Lexus's house.

Rgds, Tony. :blink:

Link to comment
Share on other sites


Hi Tony,

I had the same problem - and fixed it.

To fix the problem, you have to hold down one of the four buttons and let the moon roof complete a cycle through opening, closing, tilting up, tilting down. Once it has completed a full cycle it will reset itself to the operation stated in the manual.

I had the same problem after picking up my car last week. After speaking with my salesman, he told me the above - and it worked. My moonroof now works brilliantly.

The sales man told me that when the car gets it's pre-delivery check items such as these are checked. What can happen during the life of the car, is that the Battery may have been disconnected and the moon roof looses it memory, and needs to be reset.

If the button pressing does not work, my sales man suggested quickly nipping back to the dealership, and they would do it for me.

I hope this helps.

Alan.

Link to comment
Share on other sites


  • 1 month later...

Hi there,

Just a quick note to say that this worked a treat for me too, many thanks to Mister D.

I have only had my 2006 SE-L for 1 month and I had noticed that the moonroof buttons seemed to be difficult to use and it was difficult to judge when the roof was closed correctly as the buttons only responded when they were held down. It had not bothered me too much yet as it was too cold to open it anyhow.

But after reading this post I practically ran outside to try the reset (calibration ?) procedure and it worked a treat. Now I have the one touch controls I should have had !

One point to note though is that the car had to be in park, it did not work when I first tried while driving slowly in a traffic jam.

If anyone else has the tricky buttons then this is the fix !

Many thanks. :winky:

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership