Do Not Sell My Personal Information Jump to content


Rs200 Cutting Off


Sean Smith
 Share

Recommended Posts

Hi guys,

As the topic indicates, I seem to be having a very tricky engine issue.

Synopsys:

For the past 4 months my car has been cutting off intermittently (once a month) while idling (once) and during acceleration (three times).

Diagnostic:

When the car cuts off I notice the engine light comes on, however, I am able to restart the car soon after with no problems. Also, and ECU scan showed no errors!

Note: For the past year I had two bad O2 sensors but I did replace them both last week and the problem still reoccurred 3 days after a full service (exclusive of replacement fuel filter). Also, the car seems be be holding back a bit when I mash the X!

Any hints as to what maybe be the root cause of this issue or where should I begin to troubleshoot?

Thanks in advance,

Seanos.

Link to comment
Share on other sites


does the 3GSE have an airflow sensor? have you cleaned that?

Good call Stav. The 3S-GE has a MAF sensor and it is well worth giving it a clean.

Have you got any mods to the car like inlet or exhaust?

Oh and welcome to LOC BTW :D

Link to comment
Share on other sites


does the 3GSE have an airflow sensor? have you cleaned that?

Yea I did clean the MAF sensor....problem happend 2 hrs after I did!

Easy to damage the wires in there so I would go for a new one first off.

Link to comment
Share on other sites


does the 3GSE have an airflow sensor? have you cleaned that?

Good call Stav. The 3S-GE has a MAF sensor and it is well worth giving it a clean.

Have you got any mods to the car like inlet or exhaust?

Oh and welcome to LOC BTW :D

Well I do have a Next Level Perfromace chip that I got off of ebay (lame I kno) but I the problem did happen once b4 I installed the piggy bach chip ( but if seem to have worsen after doh)

Link to comment
Share on other sites

does the 3GSE have an airflow sensor? have you cleaned that?

Yea I did clean the MAF sensor....problem happend 2 hrs after I did!

Easy to damage the wires in there so I would go for a new one first off.

Ok...but I'm 100% sure the sensor is not cheap..so I wouldn't be to hurry to change it unless I really need to!

Link to comment
Share on other sites

does the 3GSE have an airflow sensor? have you cleaned that?

Good call Stav. The 3S-GE has a MAF sensor and it is well worth giving it a clean.

Have you got any mods to the car like inlet or exhaust?

Oh and welcome to LOC BTW :D

Well I do have a Next Level Perfromace chip that I got off of ebay (lame I kno) but I the problem did happen once b4 I installed the piggy bach chip ( but if seem to have worsen after doh)

Recap - get that out right away, the car is probably running "rich" with that in.

Link to comment
Share on other sites

Go back to the set up you had when it was OK and then see how you go.

These cheap "performance" mods just don't work "full stop". All they do is what they say "fool" the sensor into thinking that the parameters are not as they are.

Link to comment
Share on other sites

Go back to the set up you had when it was OK and then see how you go.

These cheap "performance" mods just don't work "full stop". All they do is what they say "fool" the sensor into thinking that the parameters are not as they are.

Yea..I guess I got suckered. bcuz my car was in an open loop ( bad O2 sensors) I just wanted sum to get me by!

Anywayzz, I will try that option and take it from there....

Thanks for the help guys!.

P.s. One off topic question doh.. what is the importance of replacing my fuel filter on my car that has done 140k ?

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership