Do Not Sell My Personal Information Jump to content


Fitting Hid Kits


Recommended Posts

Hi to all,

My HID kit from HIDs-Direct.co.uk arrived the other day and naturally couldnt wait to get round to fitting it yesterday.

I connected it all up before installing the bulbs into the headlight or securing the ballasts and it was a good job I did as they dont seem to work :-(

Now as BOTH lights are not working I am guessing that I have not been sent faulty goods. My wiring is all fine as my halogen bulbs worked fine when I swapped them back.

Now I was wondering having double treble checked that I had the wiring all connected the right way, is there something else really silly that I am missing, or have forgetting to do?

I bought the 9006 type at 6000k, thats correct isnt it?

Help advice thoughts all welcome?

Bill

Link to comment
Share on other sites


Thats the correct bulbs mate, have you tried turning the bulbs round the other way ?

Same thing happened to me but when i put the bulbs ( brown holder ) round the other way, they worked,

Good Luck.

I thought that...but there is a groove on one side and the clip catch on the other meaning they can only fit one way around?

Should I attempt to force the power clips together the other way around then?

Link to comment
Share on other sites


A lot of the HID kits are wired the opposite way for the IS200, if you turn the connector round on the ballast they should light up, for some reason the wiring is back to front so the pos and neg go to neg to pos on the units

As in

neg to pos and pos to neg so wont work, so just have to flip the plug over on the ballast so it goes +to+ and - to - and it should work? And on most wiring plugs you can pop the plug pins out and swap the over so there the right way round making the plug fit :)

Bit of a dodgy explanation that :lol:

Link to comment
Share on other sites


Thats the correct bulbs mate, have you tried turning the bulbs round the other way ?

Same thing happened to me but when i put the bulbs ( brown holder ) round the other way, they worked,

Good Luck.

I thought that...but there is a groove on one side and the clip catch on the other meaning they can only fit one way around?

Should I attempt to force the power clips together the other way around then?

swap the wiring around ! normally to the ballast unit

common problem for some strange reason

(beat me to it again chris !)

Edited by Bazza
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership