Do Not Sell My Personal Information Jump to content


No Display On Sat Nav Screen


Recommended Posts

Hi

I'm a new member to the LOC, having bought an X reg IS200 Sport last week. My car has a sat nav system built in, but there is no display on the screen. Everything seems to be mechanically operational in that the screen flips up and beeps when buttons are pressed, and the CD unit in the boot is working (although there was no CD in there). Even when I put an ordinary CD in the unit there was no display on the screen, even to tell me that it was an invalid disk.

I realise I would have to get hold of a navigation CD for the sat nav to be operational, but I don't think shelling out a hundred quid for a disk is a good idea when I don't know whether the screen is burnt out and beyond economical repair.

I have read the other posts relating to the IS200 sat nav system, and the lack of any kind of display does not seem to have cropped up, so if anyone has come across this problem and can help me, even if it's to say it's a hopeless case, I'd be very grateful.

Many thanks

Michael

Link to comment
Share on other sites


As a starting point have you checked all the fuses? You're probably right that it should say something even if the wrong CD is in there.........

If the fuses are all fine, I'd pop into your local dealer and ask to borrow a CD to test out whether the system is working - they should be happy to do so :)

Link to comment
Share on other sites



check the fuses mate. most likely its that. isit a sandard headunit?

Hi Asi

Thanks for the suggestion, and I don't mean to sound like an idiot but I can't get hold of an IS200 manual, and can't even find the fusebox, let alone identify which fuse relates to the sat nav screen. It looks like a standard unit, in that I've seen a few other IS200s with the same unit.

Thanks again

Michael

Link to comment
Share on other sites

Yep they're standard fuses so not hard to get hold of............as Asi asked before, have you got the standard stereo in there or has it been replaced? That's the other thing that needs to be there to make sure it works.

Link to comment
Share on other sites

Yep they're standard fuses so not hard to get hold of............as Asi asked before, have you got the standard stereo in there or has it been replaced? That's the other thing that needs to be there to make sure it works.

Yes, have asked my friend, and it's the standard one.

Link to comment
Share on other sites

oops sorry passenger side. thanks stevie

I found the TV fuse and changing this did not make a difference. I noticed when it was taken out that the sat nav lid did not flip up or beep as it had done before, so I kind of figured it couldn't be that before I'd put the new fuse in.

I can't see any other fuse that might relate to the sat nav screen. There was one labelled "dome" which I didn't know, but changing this fuse made no difference either.

Link to comment
Share on other sites

it sounds like the canbus connection isnt recognized.

are you sure that you have the oem stereo?

if so check all of the connections to the back of this are working...

Link to comment
Share on other sites

hmm strange. maybe a loose connection

I've had the sat nav unit out (had to remove a mobile phone bracket that was lodged behind the stereo unit) and there was nothing visibly wrong with the connections at the back of the unit that I could see, but I don't really know what I'm looking for. Can't believe I'm the IS200 owner with this problem? It's driving me nuts!

Link to comment
Share on other sites

I've just had the sat nav unit out again and there only seems to be two different connections on the back. One for the ground wire and the other is a load of leads attached to one connector. I took two photos, one of the wires coming from the dash and one of the back of the unit, but I don't know how to insert them. Tried the "insert image" button and it just asked me for the URL of the image's location.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership