Do Not Sell My Personal Information Jump to content


Dash Rattle


Recommended Posts

Hi guys,

I`ve done a quick search through old posts, but not found any answers....

I`ve got a T plate is200 which has just developed a rattle behind the passenger side of the dash. It sounds like the indicator is on, but randomly...??

Any one got any ideas?

Thanks

Phil

Link to comment
Share on other sites



The air conditioner on mine is doing similar thing. When it has to mix the cold and warm streams, it starts clicking. If I set temperature way too high or way too low, it stops.

Haven't really found a solution to that yet.

Link to comment
Share on other sites


Does the a/c stuff work ok when you try and change the direction of where the air is coming out ? It might be one of the motors that is used for this, e.g. there's one that sends the air either up/middle/down, and another one that is used to switch between fresh air and cabin air when you press the recirculate button, plus a third that mixes the hot/cold air. They're just to the right of the glovebox, behind the instrument panel. Might be one of those that is sticking ?

The blower motor (big fan etc) is right behind the glove box, you could always pop out the glove box (squeeze in the sides and it drops down, spilling its contents on the floor) to see if that gives you a better chance of hearing exactly where the noise is coming from. If it only happens when you're driving, take along a passenger and get them to try and help pinpoint the source.

Link to comment
Share on other sites

The air conditioner on mine is doing similar thing. When it has to mix the cold and warm streams, it starts clicking. If I set temperature way too high or way too low, it stops.

Haven't really found a solution to that yet.

That sounds like a problem the air mix servo motor. See here for a troubleshooting guide for that, sounds like it might be not working properly. That one is not too hard to get too, it's behind the glove box, to the right.

Link to comment
Share on other sites

That sounds like a problem the air mix servo motor. See here for a troubleshooting guide for that, sounds like it might be not working properly. That one is not too hard to get too, it's behind the glove box, to the right.

Thanks, mate!

I'll have a look on that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership