Do Not Sell My Personal Information Jump to content


Throttle Body Crunch/click?


Recommended Posts

Hi all,

been having a few issues lately and am slowly chugging through them now...

When i turn my key to ignition (dont start the engine) i get a sort of click noise from near the throttle body (may be from a relay near it)

And then when i turn my key back to the position where it can be removed the throttle body makes a "mechanical crunch" noise ive held the return spring at the side of the throttle body while the key is turned back and the whole assembly seems to vibrate while its crunching!!!

The car also feels under powered lately, i was wondering what the effects of a duff tps sensor would be? could this be the root of the problem?

Any help would be great! im pretty stuck on this one and im reluctant to take it to Lexus themselves as i know i could sort this myself (if i knew what was wrong lol)

All the best

Lewis

Link to comment
Share on other sites


so its nothing to worry about? i did think that originally but it seems to loud to be normal, plus it never used to do it??? Ive also noticed after a little bit of investigation today that it seems to make the same rough/crunching noise as i let off the throttle (revving it on the drive not actually driving)

i might strip the whole unit down and see whats going on :-(

Link to comment
Share on other sites


  • 1 year later...

first off....sorry to dig up an old thread guys!

i never got to the bottom of this issue, just pushed it to the back of my mind

but heard it crunch when i parked up the other day in a quiet multi story carpark and the sound was echo'd too much for me to ignore!

i hooked up the OBD and checked throttle pos...

it came out as 15.8% with my foot off the pedal (tick over % ?)

and 79.6% with the loud pedal flat on the floor??

is that a normal'ish reading as ive read that the obd could be outputting a wierd reading???

Link to comment
Share on other sites

I can't comment on the percentages as I don't know any of the techinical bits for the TB.

But I can confirm that it is supposed to sound like that, it's just the springs and the two halves of the butterfly vavle system (cable operated and servo operated) catching up with each other and moving around.

I know it sounds like it's broken, but that's just how it is. lol

Link to comment
Share on other sites


awesome! Hearing someone else say thiers sounds broken too is strangely comforting! :eerrrmm:

i know what you mean about the springs and the two halves of the throttle, ive seen them wriggling around as the ignition is turned on and off more times than id like! lol!

the OBD percentages i got arent a big worry (unless theres some power to be gained somewhere :devil:) they were just another thing playing on my mind!

would be interesting to see what other peoples obd %'s were though!..............

Link to comment
Share on other sites

i hooked up the OBD and checked throttle pos...

it came out as 15.8% with my foot off the pedal (tick over % ?)

and 79.6% with the loud pedal flat on the floor??

is that a normal'ish reading as ive read that the obd could be outputting a wierd reading???

Surely and logicaly the percentage should be 100% if you had your foot flat? I have no idea like, but thats just my thought.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership