• Content count

  • Joined

  • Last visited

Community Reputation

12 Good

About polish

  • Rank

Contact Methods

  • First Name

Profile Information

  • Gender
  • Lexus Model
  • Year of Lexus
  • UK/Ireland Location
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Restoration
    Car Modification
    Road Trips
    Food & Drink
    Computers & Electronics
    Arts & Crafts
    Sports & Leisure
    Health & Beauty

Recent Profile Visitors

1,117 profile views
  1. sorry for delay in answering, but been down with the bug ,on return trip from Manchester car seemed to be very sluggish needing a lot of revs to get/keep going.put it into sport to use paddles through road works, kept in gear 2/3 whilst clear of road works.when onto unrestricted road went upto 70[honest] car was feeling better in fact a lot better,back in drive car as should be .no more problems. next day car behaving as should so far, as you recall weather just before exmas was spring like ? been out sat/sun heavy frost but every thing ok .reading your reply's and LEXUS hull [just a satisfied customer] I am putting it down as stuck brakes .regards polish p.s happy new year
  2. merry exmass to one and all , Informed by daughter that I was to play father Christmas this year to the grand kids. [they live in Manchester] all parcells duly picked up wrapped from various outlets ,one more to pick up t, r, us, Scunthorpe. jumped in car, started ,into reverse let go the brakes engine revs and there is no movement,no brakes on no electronic brakes on .nothing then a loud bang., car shot backwards at full tilt,had to stamp on brakes fast .sat for a moment thought it was stuck brakes, into drive and gingerly try car ,seems ok drive down to lights ,sit there.when lights change car again ,NO GO revs rise again then again loud bang car shoots forwards [not good image of one year old LEXUS,]. anyway turned around got home phoned up hull LEXUStold the story asked me to come straight in did a full check on car brakes found nothing wrong no sticking pins ect.car running perfect went home .next day 23 car was ok sunday drove [crawled] to Manchester on m62 car faultless and has been up to now? has anybody else had or heard of this before old friend said it could be the steel band in the cvt box .any info would be good thanks all ,PS must put a big thanks for HULL lexus put themselves out for me at closing time and the offer of a curtesy car .
  3. HI Allan, my GS 66reg also reads out text , all I ever did was Bluetooth my phone to the car. every thing worked . all I do is press the phone icon on the steering wheel for it to begin, hope this helps.
  4. same here had Volvo for 20 years then RX lexus[3]then had drive in GS loved it ? so I bought one lovely car,every time I drive it I have big grin on my face .Norman go for a drive and watch the faces of the posers with there X5 dower I would say , give it another go or try another car then get back into yours sorted .good luck
  5. hi all interesting thread, my first Lexus was a 400 a.w.d then 2 450h the last one grey /grey was excellent could not fault it in any respect, BUT there was allways something missing?. I have allways had sports cars [ tryumph] upto getting married at 45 then saloons, jags/tryumphs 2 ford v6s in south Africa then back here Volvo v70 but something was allways niggling me .service came GS 300 was the car I was given to run around in ,problem solved I felt at home straight away ,car as the RX is faultless but when I drive the GS I allways get out with a big SMILE on my face now done 3000+ miles readout on dash 52.5 MPG, just had a key dragged down near side front curtesy of some brain dead moron in scarborough.this now fixed with my tame local sprayer PHIL. thanks pal .hope that tries to explain how I feel [would still like a red triangle throu]. polish
  6. welcome you can set the auto lock in settings also voice. I asked my dealer for a user manual and they ordered it for me ,took two wks, but found it invaluable plenty to look at ,polish
  7. Professional Detail

    steady there boys ,the car looks great, period, your pleased with it . it looks fine to me ,so lets stay nice and friendly . this is an informative sight and lets not start getting shirty .everyones opinion counts, some are more informed than others share your knowledge to the rest of us mortals .
  8. old newspapers are great at cleaning and polishing glass. I'm so doddery now that my other half cleans the inside of the car warm water/VINIGAR is what she uses, handed down through the female line, never argue screen always clear and bright never any residue left on glass .
  9. congrats rayaans , love the rose leather ,that's what I wanted in my GS 300h , but lost out to her indoors! as she says you drive and watch the road. hope you post some nice picks when you've valeted it properly .
  10. very nice and nostalgic, mine was AM db2/4 or Alvis td 21 convertible 1962 lovely car local doc had one .wouldn't sell when I came out of forces .now I just keep dreaming
  11. hi I would check on honest john regards warranty claims and electric gremlings my nephew ,bough one [big works bonus] had it for 2 years . It was in garage 7months twice called me to pick him up[ RX450h] he now runs GS, that's why I changed after driving his GS . any way good luck with car hope you have deeper pockets than with the Lexus .ps pick up was when he broke down ?
  12. i have 1864 miles on clock now car getting better the more I use it, tank readout on dash gives me 48.7 this is on last run to scarborough at 60mph car with just me and wife . only fault was noise from tyres [standard dunlops 17 inch] this was due in most part from bad road surface, bonus on run found the newly improve dab service in this part of Yorkshire gave exelent sound with NO fade. polish
  13. Hi ALAN my man at hull says the beeps are speed camera's,allso the last 2 GS models have it fitted so you should have it didn't know if it could be turned off .B
  14. GS 300h engine problem

    hi Rado , I had the same feeling that something was holding me back . I did a few checks and came up with the hold button was active even when I had set off,[I thought it self released] I pressed the button again and the car speeded up ?. I tried it again same thing. don't no if yours will react the same but worth a try