kellogsj

Members
  • Content Count

    326
  • Joined

  • Last visited

Community Reputation

19 Good

About kellogsj

  • Rank
    Advanced Member

Profile Information

  • First Name
    John
  • Lexus Model
    IS 250
  • Year of Lexus
    2011
  • UK/Ireland Location
    Merseyside

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Is there any difference between the 2 osram bulbs in this thread. Sent from my iPhone using Tapatalk
  2. Hi Ahmed, I changed the bulbs over, and both are still working fine. Sent from my iPhone using Tapatalk
  3. I’ve only ever owned 2 cars, both are 250’s. I’d like a GS 450h in the future. Sent from my iPhone using Tapatalk
  4. Thanks a lot Ahmed. Which model do you have. Sent from my iPhone using Tapatalk
  5. Thanks for sending me the link. Let’s hope it the bulb and not the ballast lol Sent from my iPhone using Tapatalk
  6. Where did you get the osrams from. Sent from my iPhone using Tapatalk
  7. I haven’t bought any replacement bulbs yet, as I’ve swapped them over to find out if it’s the bulb or ballast that needs replacing. Thanks for your help. [emoji1303] Sent from my iPhone using Tapatalk
  8. Will do and thanks for you help. [emoji1303] Sent from my iPhone using Tapatalk
  9. So should I switch bulbs back over to original side and just replace the one which was on the drivers side which was originally the one which was causing the problem, or leave as is and see what happens. Sent from my iPhone using Tapatalk
  10. It was the drivers side bulb which was flickering then going off. But now that bulb is on the passenger and passenger side one is now on drivers side. Everything seems ok now at the moment. My mechanic mate said all connections seemed really tight and where in good condition. As you say they’ve probably never been touched and are more than likely original bulbs. Now I’m confused lol Sent from my iPhone using Tapatalk
  11. I got my mate who’s a mechanic to switch the existing bulbs over and both have stayed on. This was done to find out if it was the bulbs that needed replacing or the ballast, but up to now everything seems ok. Is this normal. Sent from my iPhone using Tapatalk
  12. Where can I get them from. They look just the job. Sent from my iPhone using Tapatalk
  13. Hi everyone, I’m looking for engine bay clips. The ones I have are loose and need replacing. I’ve ordered some off eBay before and they weren’t much good. Apparently there are different sizes to go on different panels. Anyone bought these before. TIA. Sent from my iPhone using Tapatalk