oldgoldlex

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

3 Neutral

About oldgoldlex

  • Rank
    Member

Profile Information

  • First Name
    Jordan
  • Lexus Model
    LS400
  • Year of Lexus
    1993
  • UK/Ireland Location
    EastLothian

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks Stuart, that's one hang of a long web link! Only problem here I think is my climate screen is in two parts and the listing is for just one part (unless the LCD screen is one long piece behind the display?). I have a clock on one side and climate screen on the other - both are unreadable.
  2. Thank you Steve, very much appreciated. I will look to get them ordered shortly. I actually sent you an e-mail just in case (with some photos of measurements). The colour baffles me sometimes. Before it looked gold, and then beige mainly and today it looks like a smokey beige verging on grey. I think the paint code is 4k7 but its definitely beige... or is it? What colour is the interior then...? Some one said teal, some say brown.
  3. Thank you for the reply. More research needed on my part then - oh the joys.
  4. My Lexus is now back in the driveway. After over two years of not seeing the car (was in storage) and some recommissioning and many pound notes later... the car is now running well again and ready for some occasional wafting! The ECU is now fixed (special thank you to Avilec Ltd on the Isle of Wight) and the car is driving much better. I still have a few jobs to do and I was hoping to gain some advice from other board members who have experience and knowledge with these cars (and just some general common sense advice too!). I collected the car this afternoon from Lexus hoping to find a report of all the 'issues' or supplementary work but sadly one was not done. They focused there time on just getting the car to run right which I understand. I then for the first time drove the car again while on route to the pre-booked Mot. In short the car drives great, but not perfect. 1. My air-con was supposed to have been gassed a year ago but it was blowing warm today and come to think of it I can not recall hearing the motor kick in or notice a change in revs like a/c normally does - will need to double check this. 2. Once reaching 30mph or so and above the car pulls to the left (I think) when braking. Its a weird feeling, as the back feels like is pulling one way and then the front goes another. Then sometimes it just feels like its the front. Strange? This will need to be done next for sure as it feels wrong and not reassuring. 3. Hearing the odd clonk up front and on the rear. 4. The drivers window feels slow to go down. I am wondering if its just dirt over time that has found its way in perhaps? Never tried the others yet. 5. Climate control screen is blurry. I asked for this to be fixed by another garage and its still the same. I am sure they sent it off to a firm but its no use and unreadable. 6. Speakers - not all are working. 7. Steering is a little off centre (had asked for this to be aligned as well but not perfect enough) 8. When driving along the motorway after a few miles and on a slight incline, I felt as if the car was ever so slightly hesitant. When under load on the incline on the motorway it would take off but as I began a little easing of pressure on the accelerator pedal it felt like it was giving a very very slight jerk or a hesitation more like. The car had not went this sort of distance in ages right enough but just curious what that could be. So, went for the Mot and it failed. However, just on the number plates which I will sort out for the re-test. The rest of it was fine according to the garage. No mention of any of my observations which surprises me a little (brakes and suspension). That's all the main mechanical bits at the moment that are annoying me. I would like to get these addressed as I want this car to be the best it can be. Any advice as to where to go or what to look for etc with regards to the above is genuinely appreciated. Too much money and time spent on it to just let it go. I could probably of bought a much newer one or a better example with what I have paid out so far, but that is life sometimes. Before the cars are banned completely I want to enjoy some time behind the wheel of it. Anyway, here is a photo as it stands now. Oh, and thank you Steve2006 for the clear indicators - they are looking rather smart!
  5. Hello Phil, just to let you know the ECU is back and now in the car. It is running again! Thank you for all your efforts and willingness to help me. All the very best!
  6. Hello, I have a 93 LS400 and the audio inside has seen better days. Now, the system in these cars is first class, but I have a speaker in the drivers door not working, the original sub is not functioning and the CD changer is toast. After 26 years I think it's due an update and an upgrade. I would like new speakers all round, a new sub, maybe a little extra in the boot, a double din nav/tv digital radio thing, reverse camera and Bluetooth. I would also like to get a digital gauge to let me know what speed i am doing as my Speedo reads in Kms. I have seen them before and there is a nice little space where I can put it. I also want to be able to lock the car in winter while leaving the engine on - I had this in a Honda which the previous owner fitted and wow it was great! Any other cool gadgets I could fit? Ejector seat perhaps? Seriously though. I don't have heated seats as it's an import but I believe it can be done/retrofitted these days? Can it be upgraded and what can I get and where? Thank you!
  7. Hello, I have a 93 LS400 and the other day I went and bought a set of alloys. My question is, will they fit without any hiccups? The wheel specs are as follows: Front - 8.5x19" ET 40 Rear - 10x19" ET 45 I want a trouble free ride - rubbing against the arches and having to cart from side to side on the daily commute to avoid potholes and worry about full lock turns are not my cup of tea. I also want to lower the car a bit and either BC coilovers or H&R springs are what I have in mind. Any help with this is greatly appreciated!
  8. Thank you for the replies. I appreciate everyone has different tastes. I actually have 16" mk4 alloys on the car at the moment and a set of 17" DHP alloys in the garage which I may use as winter wheels. runsgrateasanut - your car is just like mine and in the same colour - can I ask where you sourced the clear side repeaters on the wing? It would be great to get a site that shows you what wheel sizes/offsets work with each car. I know there are a few wheel fitment guides online, but finding ones that cater for aftermarket wheels and different (perhaps unusual/rare) sizes would be great. I have already purchased my new wheels and I have attached an image below.
  9. Hello guys, I have just purchased a set of alloys and I just want to ask if they will fit without any problems. The car is a 1993 LS400 and the wheels are 8.5x19 with a 40ET offset for the front and 10x19 with a 45ET offset for the rear. I want the car to drive well (everyday use) and still maintain a level of comfort. I also want to change the suspension to BC coilovers with a very small drop in height just so it looks right. My concern is will this set up be possible and will I need to roll the arches in case of rubbing? It's an expensive way to find out if it's not going to work. Many thanks
  10. I will do Phil, thank you again for being so decent towards me in trying to help out. Speak soon
  11. Thank you Phil. I actually just got a call an hour ago from the ECU repair firm who said they think they can repair mine. I asked what was wrong and he said the capacitors will probably need replacing as he found some minor leaking on the board. He mentioned he was going to get it under the microscope and test some other parts on it but felt confident enough and said it would be finished tomorrow and in the post tomorrow evening. The bill came to £250 plus VAT. I really appreciate your kind efforts in trying to help me out with your other ECU, but I think at the moment to save you any hassle I will wait until mine is back and see what happens when Lexus plug it back in. Would this be ok? Thanks for the link to Lextreme, that looks like a great site with loads of info on there! I was actually thinking the other day how good it would be to have a turbo!!!
  12. Thank you Phil again for your kind efforts. If you are able to send the one you have I would be most grateful. I would wait until the ECU repair folks have come back to me and just as a back up I could try both to see if they work. As of yet I have not heard when its due to be looked at, all I know is they have it. With regards to the capacitors, I have no idea how many there was. I did read LSCowboy's post on club lexus and he mentioned that the capacitor quantity changed over the years. I should have looked at that when I was looking inside the ECU.