Joey-is250

Members
  • Content count

    27
  • Joined

  • Last visited

Community Reputation

3 Neutral

About Joey-is250

  • Rank
    Member

Contact Methods

  • First Name
    joe

Profile Information

  • Lexus Model
    IS250
  • Year of Lexus
    2007
  • UK/Ireland Location
    ---------Ireland-----------

Recent Profile Visitors

606 profile views
  1. Ebay coilovers

    Thanks for the help
  2. Ebay coilovers

    That's the job.looks even now.what preload would ya use for a road car?
  3. Ebay coilovers

    Fair difference in them.be interesting to see how it all works out when you get them back in other way round.keep us updated.
  4. Ebay coilovers

    Is that the rear down as far as it will go? I can see what you mean about swaping them around from the first pic looking at the thread gaps left. Let me know how ya get on with changing the dampers around.Thanks
  5. Ebay coilovers

    Anyone using the coilovers in the link below?At the price I'm thinking of giving them a go but would like get some feedback off anyone that has purchased them. http://www.ebay.ie/itm/for-Lexus-XE10-IS200-IS300-XE10-GXE10-JCE-5-Year-01-05-Coilover-Suspension-SCB-/222179294513?hash=item33baeafd31:g:GeoAAOSwhOVXfih-
  6. Lexus Is220 Or Is250 Amp In Boot

    Looking for the amp in boot for speakers,Must have part number toyota 86280-53110 .Can put up pics if needed and will need posting to Ireland,thanks for any help.
  7. I have a problem with volume on a standard headunit in a 07 is250.It just the ordinary one,not sat nav or ML system After about half hour to an hour of driving the sound goes totally off but headunit still functions perfect just no volume even with the volume number up to max. First time it happened turning on and off headunit made no difference but stopping car and restarting the car the head unit worked perfect again.When no volume working turning on the head unitthere 2 popping noises true speakers which isnt there when its working 100% Today it did it again but this time turning on and off car didn't fix it but came back to car after about an hour and it working again perfect. Does it sound like the amp in the boot the problem?Checked all connections and used contact cleaner after first time it done it and all seem good.Also amp does not fell overly warm or over heating. Thanks for any help or if anyone has an amp for sale at reasonable money that i could buy to rule it out please let me know.
  8. Called into main dealers today and he looking into getting the one with the slots for me monday.
  9. Finally got around to pics.Taken with a camera phone and dont show up nothing like how yellow and worn they looked.They really were very faded and yellow on the top half.They look as new now. Before After Before After Drivers side done,passengers side untouched.
  10. Maybe the ones with 3 slots either side are better fit and hold tighter, Anyone used the one i have with no slots or should i get the ones with slots?Don't want to damage anything.
  11. I ordered a oil filter wrench in toyota and received the one in pic below.Gave them the reg and was told its correct type for is250. Was looking online and see ones that have 3 spaces on either side as in third pic. Do i need the one with the 3 spaces either side or is the one i received correct? What i have. Do i need?
  12. Have a few in the phone i'll get them up tomorrow,hard to see in the pics how bad they really looked before starting though.
  13. Upgrading Headlight Bulbs

    I'm hoping to stay with halogen bulbs as HIDs are illegal here now so not worth the hassle of fitting them. Can get a set of 6 osram nightbreakers for around €100,anyone using them find much of a difference from standard bulbs?
  14. Upgrading Headlight Bulbs

    Ya it has halogen bulbs fitted.