jimjamjohnny

Members
  • Content Count

    58
  • Joined

  • Last visited

Community Reputation

13 Good

About jimjamjohnny

  • Rank
    Member

Profile Information

  • First Name
    John
  • Lexus Model
    is250se-l
  • Year of Lexus
    2006
  • UK/Ireland Location
    Kent

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. jimjamjohnny

    PWR mode

    Just driven down to devon for a week, eco mode was fine whilst on the motorways but noticed a difference when negotiating the hills and tiny roads where my car seemed totally gutless. Switched to the power mode and seem to get a much better response. Can't see any discernable difference in consumption yet but I'll leave it on til I'm back on the motorways now I guess......😊
  2. I really really wanted a rx300/350, but just like you i couldn't find a really good one with low miles in the 4-5k bracket So I bought the is250se-l. I had a lovely is200, 7 years ago and should never have sold it.wanted another lexus ever since. You will find one And I will find that rx300.😊
  3. Keep looking, they are out there,I bought this 4 weeks ago for £4250. 65k on the clock
  4. It's already gone I think.not surprised at that price
  5. jimjamjohnny

    Telephone

    Right I've sorted the phone issue,but trying to use the voice tag is driving me mad,keeps telling me the voice tag is empty,but I can't see anywhere to put a number into it.😞
  6. jimjamjohnny

    New owner ... RX 400 09 plate

    Welcome to the madhouse sir.😜
  7. jimjamjohnny

    Telephone

    Thanks I will give it a bash.😊
  8. Sorry another topic for you guys and girls Have finally got around to trying to set up my phone. With the car,It seems I can recieve calls OK But calling someone is a no no....it just says network has disconnected Yet if I use my phone to call,it connects via the car Also I can't Bluetooth my contacts and I don't fancy entering 100 contacts one by one...... Am I being dim,?😳 My phone is a galaxy note 8.
  9. Well I've had my baby almost a month now,and have just finished a tank of petrol.the computer says average 27.6 mpg.and tank average of 35. Is this good/bad.?
  10. jimjamjohnny

    Newbie

    Welcome to the club 😊
  11. Finally got round to cleaning it and got rid of the snow and salt I've had it 10 days now, and still find little things in it that I never knew it had I think I like the interior,but I'm not sure.
  12. Maybe that is what I did this morning then........
  13. So are they just pressure fed.? Seems strange that it's just one.
  14. jimjamjohnny

    Music

    OK I'll give it a bash Thanks