Do Not Sell My Personal Information Jump to content


Recommended Posts


Just a quicky does anyone know which the radio amp is in the boot for a 93 LS?

Thanks

Mat

It's in the boot on the upper left hand side, By the hinge for the boot. You must undo the four top screw and three bottom to remove the carpet. You'll see it sitting on the left with phillips written on it.

The door switch ecu & chip is to the left of that about three inches away if you ever need to do a chip change for new master keys.

I know this, As just got new keys and chip put in this morning and can now open the doors by remote(Cool).

Link to comment
Share on other sites


Awesome thanks mate. How much did the keys and chip cost?

Mat

Two master keys(Cut for my car already) and chip where £160 from Lexus. All woked and installed in about an hour. Would do it faster next time, Now I now what to do.

Does your rear parcel shelf speaker work??

My speaker works, But get no sound from it. I've tested the speaker on it's own and works fine.

So I'm assuming it's the amp maybe.

If you're removing your amp to replace with after market system, Then can I have frirst option to test on my car to see if this is my problem.

Link to comment
Share on other sites

Hi there mate

Funny you should mention the sub as i have the same problem with my sub, it works but it doesnt produce any out put!! so im afraid we are both in the same boat. I've putting in an after mark amp and sub in, but on the lexus there are two wiring diagrams. One that shows one amp to run the speakers and woofer or the second diagram that shows just an amp to run the sub. I have a 93 LS and im not sure which is for my car - any ideas?

The reasons why i ask is that ive encountered a problem with the left hand side of the speakers, as they have started to crackle when i play CD's, where as the right side are fine. I,m baffled

Best regards

Mat

Link to comment
Share on other sites


Hi there mate

Funny you should mention the sub as i have the same problem with my sub, it works but it doesnt produce any out put!! so im afraid we are both in the same boat. I've putting in an after mark amp and sub in, but on the lexus there are two wiring diagrams. One that shows one amp to run the speakers and woofer or the second diagram that shows just an amp to run the sub. I have a 93 LS and im not sure which is for my car - any ideas?

The reasons why i ask is that ive encountered a problem with the left hand side of the speakers, as they have started to crackle when i play CD's, where as the right side are fine. I,m baffled

Best regards

Mat

I've put up a new thread to find a solution. Does your rear sub woofer work on it's own by testing it on another car?

As sonn as I know it's the amp my cusion can fix them, But I need to find the parts needed for the board from maplan before travelling 30 miles for him to do it. That's if it is the amp.

I think I'll post it to him to check it out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership