Do Not Sell My Personal Information Jump to content


Premium Sound System?


Recommended Posts

Hello, picked up our RX300 two weeks ago, got a few niggles with it that are being sorted under the warranty, its a 53 year 03 CE-L model, we have the mark levinson sound system in it and from my understanding this is the premium system, well im not sure if ours is faulty in some way (it is actually as the cd has error 4 on it, this is being replaced uunder warranty though) as im not impressed by the sound, it just doesnt sound 'nice' if you know what i mean, also i thought it was 11 speakers yet i can only find 9, 7 in the front and then 2 in the back doors. Ive looked under the seats to see if the amplifier is there but i cant find anything. Is this the case with them or could the fault i have be causing poor sound quality?

Dont get me wrong its ok, its just not as good as i was expecting. I used to drive a top of the range c-max with a sony stereo and that was far better than this one

cheers ste

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership