Do Not Sell My Personal Information Jump to content


jay m

Established Member
  • Posts

    499
  • Joined

  • Last visited

Profile Information

  • Gender
    Male
  • Lexus Model
    IS 200

jay m's Achievements

Proficient

Proficient (10/14)

  • First Post
  • Collaborator
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. Happy Birthday jay m!

  2. I dont think its the battery but to be honest i have so much stuff wired in it could be anything. It has been happening for around a year and as i got the emanage installed a few weeks before hand i figured that this would be the problem, also the power light on it remains on after turning off the ign. When the emanage was installed i asked for new injectors to be added too, this caused mass confusion with the "mechanic" and in the end i got it back with the oem ones left in. This seems too much of a coincidence that now occasionally when i turn the car off there is a whining sound coming from the engine bay and when the injector relay is unplugged it goes away. It used to take several days to drain the battery and now its a matter of hours, although saying that i dare say that with constant draining it probably has took its toll on the battery, just not too sure where to start... In writing this i had to go outside to jump my car to stop the alarm going off which cant be doing me any favours with the neighbours lol.
  3. Alright folks, Basically as the title suggests, my battery drains every day, every time i want to drive somewhere i need to jump it, been like this for a year or so, needless to say i barely drive it anymore but i want my car back! I think it is something to do with the ecu (E-Manage ultimate) as ever since i got it installed i have been experiencing trouble. Initailly i thought it was a relay staying on as when i unplugged the injector relay in the engine bay a soft whining noise would stop. Replaced that and still the same. If anyone has any suggestions at all that would be great as im completely lost, even wiring diagrams would be helpfull so i can sit down and properly think about this. Or places to try, or people to ask etc? I want my car back lol.
  4. Cheers guys, As for the hippo sleek kit i was also considering this but seems near impossible to find. Just bought a new laptop and had all the bookmarks saved in the old one, will just have to keep searching lol. Not having much luck at all though, anyone any suggestions?
  5. Alright fokls, I was looking for a C west front bumper and found one for sale at mad motors at a really good price, unfortunately they no longer sell them, dam. Next place i was going to try was Lextacy (unless anyone has any other suggestions?). How ever my main problem is that they have it lised under IS300, as far as i know they are the same but didn't want to take the risk without asking first. This basically stemms back when a friend bought IS300 side skirt and they were slightly longer then needed, however i think this ended up being a problem with the supplier but not sure.
  6. The central dome light is 269/Festoon 31mm. The map light is BA9. I've swapped both of mine for multi-LEDs (36 in the dome, 6 in the map light). Where did you get those from mate, had a look but can only find up to a 4led for the 269 and no luck finding a ba9 led at all lol.
  7. Oh by the way, does anyone know the names/code of the bulbs in the lights both in front and behind the sun roof? Got the led bug now lol.
  8. Cheers Got it fixed, well sort of, one of the leds had been crossed over inside the holder and blowen the fuse. Dont know how or when it went as it was fine earlier but oh well, got it fixed so just got to buy a new led for over the fuel guage and all is fine again. Cheers
  9. Alright folks, I finally got round to changing the bulbs behind the speedo as they had been broken for months. I decided to replace them with leds. I tackled the ign ring first and that was easy enough but when i put the bulbs in the speedo none of them were lighting up. I thought there was a small chance that i had put them all in the wrong way round so changed them over and still nothing. I then also noticed that none of the lights around the temp controls etc were coming on. Went to check the fuse and i guess its the "panel" one but all is fine, checked the rest in the drivers foot welll and they are all fine. Is there a fuse some where that i dont know about or have i done something royally wrong lol.
  10. jay m

    1jz-gte

    alright follks, Dont suppose anyone has a spare 1jz lying in a cupboard anywhere? Was supposed to be getting one sent from japan through an importer but they have been killed by the recession :( Any ideas please let me know, it would be everything im after but anything is better than nothing lol. Jay
  11. Should also be noted that the charger is still on my car although should be off very soon! As Stav said they run straight out the box, everything needed for it shall be included along with instructions on how to fit, its not too difficult to do, took me an evening and a morning to get it in and running and im no mechanic lol. This was my car running the charger, manifold, sports cat and exhaust. I later got an other ecu, fly and clutch fitted which brought me up to 251bhp!
  12. Alright guys as the title says, It was reserved for Cam, but since he's pulled out ive decided to consider offers on it. And as im planning something rather expensive please be generous lol. Comes with the induction kit and apexi filter, larger pulley and belt can also be included if required. Any pics or extra info required please feel free to ask, im based in Aberdeen but will be travelling up and down to london 3 times in the next 6 weeks so i could meet for collection or what not. Thanks Jay
  13. Thats cause the clutch is actually for the Altezza, you have to reuse your standard release bearing. Stav So is this clutch AND release bearing for the Altezza? If so do u have any pics and whats it like, condition/driving wise? This would make a lot of sense, its not hugely different but enough for me to not fit it lol. Yes mate, however i shall also include the release bearing for the is200, i bought it when i discovered the one supplied didn't fit and for the case of £45 i felt it was worth it in case the previous one packed in. So the bearing is the same age as the clutch and genuine lexus part. As for the driving its slightly more precise but to be honest its still perfectly liveable, i drove my mates car who has a twin plate and it was nothin like as harsh. I find it perfect for the car imo, however when the g/f drove it she stalled first time then got used to it within 2 mins, saying that though she's used to a 14 year old legacy which still has the standard clutch etc lol. No pics at the moment, i took one when it was lying in my garage once it got delivered, will try find it. Cheers mate, im very intrested in this, my release bearing squeaks at times too so could also do with being replaced, im not 2 fussed as too how harsh it is, ill get used to it, i do the odd drift day now and again so as long as it can take some stick B) Nice one mate, well give me a shout if you want to have first dibs on it when it comes off the car, should hopefully have a rough date tomorrow.
  14. Thats cause the clutch is actually for the Altezza, you have to reuse your standard release bearing. Stav So is this clutch AND release bearing for the Altezza? If so do u have any pics and whats it like, condition/driving wise? This would make a lot of sense, its not hugely different but enough for me to not fit it lol. Yes mate, however i shall also include the release bearing for the is200, i bought it when i discovered the one supplied didn't fit and for the case of £45 i felt it was worth it in case the previous one packed in. So the bearing is the same age as the clutch and genuine lexus part. As for the driving its slightly more precise but to be honest its still perfectly liveable, i drove my mates car who has a twin plate and it was nothin like as harsh. I find it perfect for the car imo, however when the g/f drove it she stalled first time then got used to it within 2 mins, saying that though she's used to a 14 year old legacy which still has the standard clutch etc lol. No pics at the moment, i took one when it was lying in my garage once it got delivered, will try find it.
×
×
  • Create New...




Forums


News


Membership