Recommended Posts

I have the standard navigation system and I'm starting to pull my hair out as it keeps flipping changing the map!  

I prefer 3D Heading Up.  So in I go to Menu-Setup-Navigation-Maps and change it to my preference.  Start navigation no issue.  Next time I want to nav somewhere else, it's changed back to 2D North Up!  I am fully aware by the way that the Home screen will show 2D.

It's been back to the dealer once and they carried out a software update...  This seemed to cure it for a short while, but now it's gone back to its normal irratating ways.  MEH

I have now been able to speak with both Lexus Cust Relations and a Master Tech at my Dealer and they have both come to the conclusion that this is 'normal'.  So every time I set to nav somewhere, I have to then change the map back to 3D.  Why won't it stay put?  The menu options are there, so it suggests I have a choice.

Is anyone else experiencing issues?

Please let me know, and then report it ASAP to your dealer so it helps to gather un happiness.  If lots of people shout, Lexus will have to do something.

Share this post


Link to post
Share on other sites

My UX F Sport navigation does the same, go to setting and set it for 2D Heading and it will always revert back to 2D North. Sometimes it will stay on 2D Heading for a couple of times but will always end up on 2D North. I have never had this with other Lexus and Toyota cars I have owned.

Any ideas from Toyota or anyone??

Phil

 

Share this post


Link to post
Share on other sites

report it, report it, report it.  To your dealer and Lexus Customer Relations. The more that shout out about it, the sooner the fix will happen.  I did the same and have been told there is a software fix coming soon.  Not sure how soon, soon is...

Share this post


Link to post
Share on other sites

Hi All, just getting the hang of my new F-Sport and the many awesome features. One thing I can't sus out is how to get into speed limits config under navigation. I'm sure I've used it before but it's now always greyed out!

I've tried with the car in Park, connected to my phone WiFi hotspot, but the speed limits menu option is  always greyed out. 

Any ideas? Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.