Sign in to follow this  
michaelevans60

Grinding Sound From Rear Of 93 Gs 300 At Low Speed

Recommended Posts

Hello all! Just joined having just got my Lexus, so this is my first post. It looks like you guys are very helpful, I took part in the Porsche 944 forum when I had one and it worked superbly - a massive help. I hope this forum works similarly!

Just got the car (sort of inherited really) 1993 GS300, 228K (!) miles with a service history and absolutely superb. Still tight as a drum. One thing though; there is a graunching sound from the rear of the car at low speeds that stops over about 10mph. Would have put it as brakes but it does not change when you apply the brakes. I'm thinking differential trunions? Any other ideas or advice to fix? All inspiration gratefully recieved.

Thanks

Mike

Share this post


Link to post
Share on other sites

May be worth checking the diff oil level. What about if you put the handbrake on whilst going slowing, could be the drums/shoes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this