Sign in to follow this  
Countrydj

Ls400 Electric Windows & Steering Wheel

Recommended Posts

My electric windows and steering wheel adjustment have stopped working. I cannpt find a fuse that has blown.

Has anybody had this problem ???

My auto-electrician needs to know if there is a "main feed" for the electric windows.

Can anybody help....

Thanks

Share this post


Link to post
Share on other sites

Mine did the same a while ago - it was a fuse, but don't know which (was under bonnet though) - A friend of mine (electrician) fixed it - he's on holiday in spain so when he comes back I'll try and find out for you if nobody else can help in the meanwhile

Share this post


Link to post
Share on other sites

Thanks Jason...

I looked through all the fuses under the bonnet and they all looked fine.

I would appreciate any further info that you can give when your friend returns.

Was your automatic steering wheel adjustment affected as well as your windows ???

Share this post


Link to post
Share on other sites

I have now resolved my electric windows problem. I fixed it over this weekend bank holiday.

The solution was two fold:

1. There is a thermal fuse (which my auto-electrician said was a relay) behind the 'kick panel' in the driver's well. It is rather large (1" x 3/4") and oval in shape.

I should have known better than to believe that it was a relay when it clearly said "P/W 30W".

This is a thermal fuse but it didn't go back to normal as it should have done. I persuaded it to return to the normal position and pushed it back in. After this all my windows, sun roof and steering column, EXCEPT for drivers door window worked.

2. Now to tackle the driver's door window. I started with the control switches embedded in the driver's door. This is easily removed. There are 3 screws fastening it to the wood-like panel and another 6 screws fastening the cover. I removed all these screws and then wondered "...where have all these springs come from...". Well this was to be resolved later. I noticed that the contacts that operated the driver's door windows were 'carbon coated' and this does not make for good contacts. I cleaned these contacts, figured out where all the 5 springs went and re-assembled the cluster.

Now ALL is working again properly EXCEPT for the switch that stops the windows being opened from the rear seats. There was a spring that should be fitted in this switch assemble but I couldn't figure out how it fitted.

I felt that it was a small price to pay to have all my windows and sun roof opening again. I will try again with this switch. I hate being beaten.

Hope this helps others who may have a similar problem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this