Do Not Sell My Personal Information Jump to content


  • Join The Club

    Join the Lexus Owners Club and be part of the Community. It's FREE!

     

Help! Rx300 Throttle Loss And Engine And Vsc Light


Recommended Posts

Hi All

My 2004/54 rx300 suffered a flat Battery at the weekend and upon jump starting I have no accelerator at all. The car starts fine but the check engine and VSC lights are on.

We have put in a new Battery as per some Google advice but no luck. We've also cleared the codes but no luck. My searching points to the TPS (throttle position switch) or TPA (throttle position actuator) as the likely culprits. Both are expensive and both are out of stock at Lexua for over a week.

I guess it could also be an ECU fault but have no way of knowing.

Has anybody suffered from this before and what was the outcome? Any other ideas welcome.

Tried tapping the TPS but nothing.

Please Help!

Link to comment
Share on other sites

Bump!

Please help! We've now cleaned the throttle body, cleared all codes, adjusted the throttle position switch and changed the Battery to a new Bosch unit but no luck. I have sent the throttle body to BBA Reman for reconditioning but am not convinced that this is the issue.

Has anyone had a similar issue and what did you do to repair it? Could it be an ECU issue?

Finally, if I buy and ECU from a breakers, can it be used or is it vehicle specific?

Please help! We've owned the car for 6 years and done 65000 miles in it and never changed even a lightbulb. We've only required normal servicing and consumables but now it's a giant paperweight that I can't move!

HELP!

Link to comment
Share on other sites

  • 5 months later...

Bump!

Please help! We've now cleaned the throttle body, cleared all codes, adjusted the throttle position switch and changed the battery to a new Bosch unit but no luck. I have sent the throttle body to BBA Reman for reconditioning but am not convinced that this is the issue.

Has anyone had a similar issue and what did you do to repair it? Could it be an ECU issue?

Finally, if I buy and ECU from a breakers, can it be used or is it vehicle specific?

Please help! We've owned the car for 6 years and done 65000 miles in it and never changed even a lightbulb. We've only required normal servicing and consumables but now it's a giant paperweight that I can't move!

HELP!

Late response I know most likely you fixed the problem by now.

But I had a very similar problem with my GS300 (different engine as I understand the RX has the V6 and the GS has the I6) I got a used complete throttle body from eBay and fixed the issed for £40 delivered.

Link to comment
Share on other sites

Latest Deals

Lexus Official Store for genuine Lexus parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via eBay links

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share







Lexus Owners Club Powered by Invision Community


eBay Disclosure: As the club is an eBay Partner, the club may earn commision if you make a purchase via the clubs eBay links.

DISCLAIMER: Lexusownersclub.co.uk is an independent Lexus forum for owners of Lexus vehicles. The club is not part of Lexus UK nor affiliated with or endorsed by Lexus UK in any way. The material contained in the forums is submitted by the general public and is NOT endorsed by Lexus Owners Club, ACI LTD, Lexus UK or Toyota Motor Corporation. The official Lexus website can be found at http://www.lexus.co.uk
×
  • Create New...