Recommended Posts

Hi all

Im a newcomer to this group and to Lexus as well as hybrids, I’ve just done a round trip from the Isle of Wight to Essex and back. Half way on the outward trip this morning, the cruise control was set at 80 mph and suddenly cut off and the caution symbol came up on the dashboard with a Check Hybrid System message, all the directional arrows disappeared from the centre screen, and the cruise control would not come back on. I continued to essex at a much slower pace but the car seemed and drove perfect. I stopped and had a cup of tea, collected the wife, and set off on return journey and all was well, the cruise control was working fine but the caution symbol was still illuminated, again about half way back the cruse control shut down and all directional arrows on centre screen disappeared and the same message came back on the dash. I’m a very capable diy mechanic, as my father was a mechanic, but hybrid is a totally new thing to me, any advise would be much appreciated. Thanks in advance.

Share this post


Link to post
Share on other sites

It could be an issue with Battery pack, may be some cell not in shape, I suggest you to buy a Techstream interface and verify with Techstream  windows software. Meanwhile, if you have a standard OBD reader, you could read the error code to have a better idea of problem.

Share this post


Link to post
Share on other sites

Don't be too worried, Lexus cars are very reliable.

Share this post


Link to post
Share on other sites

I had a very similar thing with my 2011 RX450 last summer. But i'm not sure what you mean by ' all directional arrows on centre screen disappeared '. However I took mine to Lexus Hatfield (the closest dealer at the time) who diagnosed the fault as being 'gearbox oil pump running out ot tolerance'. I think the code was maybe something 502 (but don't quote me on that!). They reset the fault and it did'nt recur until Lincoln on the return journey. I then took it to Lexus Hull who diagnosed the same problem and changed the gearbox oil pump under warranty. Apparently it is a not an unheared of fault . The oil pump only provides circulation through the oil cooler I think as it does not appear to be anything bigger than a washing machine pump out pump. Either way I hope it's not anything more serious.

Bri

Share this post


Link to post
Share on other sites

If the car is new to you and you have a warranty of some description then now is the time to make use of it... this sounds like an unusual problem and one for a dealer to sort

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.