Recommended Posts

After some ideas:

I have a Gen 3 250 and I’ve noticed this noise twice now. Cold mornings on both occasions, it sounds like the noise is coming from inside the engine bay  - it’s more of an electrical noise, like a electric passing through a switch that’s stuck (if that makes sense). Lasts for 3-4 minutes. Turning the radio and blower off has no effect. Car seems to warm up and the noise is gone. Doesn’t sound healthy!

Any ideas folks?

Share this post


Link to post
Share on other sites
 

1 hour ago, Ben1001 said:

 - it’s more of an electrical noise, like a electric passing through a switch that’s stuck (if that makes sense).

You can hear electricity?  Cool :cool:

Share this post


Link to post
Share on other sites

Never heard electricity passing through power lines?

Share this post


Link to post
Share on other sites

No can't say I have, but even so, there is a big difference between 400kv and 12v

Anyway back to your issue, have you checked the vents for the heater inlet to make sure it is clear of leaves, and any debris? 

Also, just a thought have you checked your power steering fluid? 

Share this post


Link to post
Share on other sites

If possible try and find out where it is coming from in the engine bay next time it happens. Possibly a relay not switching correctly, although I'd expect something to not be working correctly if that were the case.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now