Recommended Posts

So have a weired issue.  Replace my egr valve with a new one.  but the VCS light, the traction control light and the EML light are all on.  I have had the codes reset multiple times but they keep comming back.  I took it to a diagnostic guy and he said its the EGR valve.  I have ordered another as a replacement for the original being faulty.  Im going to get it fitted on the weekend.

The issue (and im probably jumping the gun) the electric windows on the passenger side, both the front and the back have stopped working.  Not sure exactly when they stopped.  But the rear one has been intermitantly comming on and off.  So my question is, could it be the switch.  Oh and i cant drop the window from the drivers side nor from their own controls.  Ive had the Battery tested and its all OK.  I need to test the power output on the EGR valve. Does anyone know what the output on those EGR ends would be?

Also any ideas on the windows issue.  How do i remove the switches?

Thanks in advance.

Share this post


Link to post
Share on other sites
 

If you had Battery disconnected then you need to reset windows, I believe the instructions goes like - connect the Battery, fully open every window one by one and close them one by one. It gets weirder as well - once I have replaced Battery and everything was fine for 3 days, but then during heavy rain I found my car with all windows fully open in shopping centre car park, so doing windows reset is highly recommended. 

Share this post


Link to post
Share on other sites

Don't forget that when initialising or re-learning windows after a Battery dis-connect you must use the switch for each window and not try and do it from the drivers switch panel posistion.

paul m.

image.png

  • Like 1

Share this post


Link to post
Share on other sites

Each window one by one using the switch on each door, all the way down then up again.

Worth checking things like your rear window heated elements after as well. Mine have played up since I've changed my Battery so I'm assuming the Battery is at fault?



Sent from my SM-G935F using Tapatalk

Share this post


Link to post
Share on other sites

Thank you.  Ill have to try that later.

Share this post


Link to post
Share on other sites

Try looking at the little L.E.D right by each switch. Cup your hands around each L.E.D to try and see if its blinking slowly.

If it is ...your windows need initializing (or sometimes referred to as Syncing) by the method outlined above.

Once done the light should be solid.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.