Do Not Sell My Personal Information Jump to content


Recommended Posts

Morning all yesterday i parked up my 2006 rx350 sel put it in park the applied the footbrake .. or so i though.. it felt quite soft when i put it on so i slipped the car in neutral only to find the foot brake wont hold the car ..... is it going to be an expensive fix or does it need adjustment.... any offers of help most grateful... thanks Dean

Link to post
Share on other sites

The vehicle uses a standard/simple drum brake system which is cable operated. There is an adjustment procedure but that normally isn't required once fitted correctly as there should be little to no wear on the system unless you are in the habit of driving with the parking brake engaged or apply it before the vehicle is stationary.

It shouldn't be expensive to repair, but needs investigating as it could be a cable fault or something within the drum brake assembly.

  • Like 1
Link to post
Share on other sites

... I think mine needed a new cable.

About £200 'ish, I think, with fitting?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership