Do Not Sell My Personal Information Jump to content


Recommended Posts

I know not many manuals have this so maybe I am alone, but the cruise control is no longer working. All I tried is replacing the Battery inside the remote, then stopped bothering about it. Does anyone happen to have solved this issue? Thanks

Link to post
Share on other sites

What country is your vehicle from? I don't believe any manual Lexus IS200s had CC - not in Europe, US or Australia. Possibly an option in Japan on the Altezza but I think even then it was only on the auto transmissions.

I'd therefore assume it is an aftermarket add-on?

Link to post
Share on other sites
15 hours ago, ColinBarber said:

What country is your vehicle from? I don't believe any manual Lexus IS200s had CC - not in Europe, US or Australia. Possibly an option in Japan on the Altezza but I think even then it was only on the auto transmissions.

I'd therefore assume it is an aftermarket add-on?

I'm located in Sweden, yes it's probably aftermarket one, but most likely professionaly fitted by a Toyota shop. The old man who had the car first for 15 years has passed away so I can't really ask him either lol. We're thinking maybe one of the sensors for the pedals (clutch brake and gas) aren't right. 

Link to post
Share on other sites

Have you located the cruise control ECU as it may have manufacturer details on it for reference to obtain service information. There must also be an actuator connected somewhere between the pedal and throttle body.

LHD, Aftermarket cruise control.......yikes! Good luck.

Link to post
Share on other sites
2 hours ago, steve2006 said:

Have you located the cruise control ECU as it may have manufacturer details on it for reference to obtain service information. There must also be an actuator connected somewhere between the pedal and throttle body.

LHD, Aftermarket cruise control.......yikes! Good luck.

Yes it's a neat little box next to the ABS, all there is is cables going into sockets and this row of switches that can be alternated between 1 and 2, like some sort of code, but I haven't touched that so it shouldn't be unsynced. I'll be looking for that actuator though, thanks.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership