Do Not Sell My Personal Information Jump to content


Help - Cd Player Not Working!


Recommended Posts

I have an '01 X-reg IS200 with the 13903 headunit (CD player at the top - type C).

The other month it wouldn't pick a disc up properly which then results in it saying there is not a disc in that slot - when there actually is, so I then had to take the unit out, and open it up to get the disc out! Pain. What actually happens is the disc end up sitting on top of the one below as it doesn get pushed back into the carrier slot far enough!

Firstly - does anyone know how to fix that problem?

Secondly - it would appear that when I put the top cover back on the unit, I must have caught the flexi cable thats at the rear right of the unit (looking top down) and its sliced it a bit, breaking some of the connections.

I now have no CD unit operation at all - i.e. when I press load, nothing happens - there are also no discs in the unit. Radio etc all works fine though.

So, does anyone know where you can get spares for this unit (details are below) or would it just be easier to try to get one from a scrappie? I don't actually need a working player, just the right model to take this flexi/FFC cable from - so does anyone have a broken unit they no longer need?

Unit is a Fujitsu Ten 122000-27900101, 13903 model, Manufacturered June 2000, Type C unit with CD player at the top. Also says, Toyota 86120-53041, serial no. A8400699.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership