Recommended Posts

Hey - So I am little bewildered by the screen display hoping folks could help.

1 - By default it seem to always display the map menu - however half the time it has be driving through fields in god only what place, occasionally it is correct.  If I set a navigation course it work perfectly. Why does the default go nuts?

2 - It will never remain on say the Audio screen, is there any way for it to remain on another screen?

3 - Are there any cool tweaks to make the display any better and how do you get the maps updated as mine seem pretty old.

Share this post


Link to post
Share on other sites

1. Not sure 

2. Hidden in the car menu is a setting that allows whichever screen you have been viewing ( climate, audio etc) to remain once selected until changed 

3.Map updates on RX unlike GS and Is needs to be done by dealer. I understand this is around £250 which is why I use tom-tom live sat nav. 

Share this post


Link to post
Share on other sites

2 - Where can Find this hidden menu?

Share this post


Link to post
Share on other sites

I can't honestly remember where. Try going through the settings which are setup related. It will be under an option for display. I know I spent about 30 minutes and then found it. 

  • Thanks 1

Share this post


Link to post
Share on other sites
46 minutes ago, olliesgrandad said:

1. Not sure 

2. Hidden in the car menu is a setting that allows whichever screen you have been viewing ( climate, audio etc) to remain once selected until changed 

3.Map updates on RX unlike GS and Is needs to be done by dealer. I understand this is around £250 which is why I use tom-tom live sat nav. 

I got the map update done on mine when I got it in Oct 2017.

It was one of the USB systems and cost £160, took about 3 hours in total including an inclusive Hybrid system check.

I much prefer the built in sat nav to the old TomTom I used to have.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 7/22/2019 at 12:48 PM, jpower said:

Hey - So I am little bewildered by the screen display hoping folks could help.

1 - By default it seem to always display the map menu - however half the time it has be driving through fields in god only what place, occasionally it is correct.  If I set a navigation course it work perfectly. Why does the default go nuts?

1. We had this exact problem on our 2012 RX450h and it was like that when we bought it. It took a good few years to finally get it fixed as frustratingly every time we took it to the dealer it would behave itself. An error finally showed up on the diagnostics earlier this year and a new Sat Nav unit was required. This has solved the problem and luckily it was covered ( which Bristol Lexus kindly fought for) under the extended warranty as the replacement part cost several thousands before the labour was added.

Prior to this, we found that running the recalibrate setting temporarily fixed the problem but it would reappear within a few days.

 

Share this post


Link to post
Share on other sites
9 hours ago, F.A. said:

An error finally showed up on the diagnostics earlier this year and a new Sat Nav unit was required. This has solved the problem and luckily it was covered ( which Bristol Lexus kindly fought for) under the extended warranty as the replacement part cost several thousands before the labour was added.

 

 

My unit was replaced under the extended warranty by Cheltenham Lexus. The camera was slower to load than on other Lexus I have owned. Their view was' our technician thinks the unit should be changed so Lexus have already authorised the repair.' Took about a week for the part as it had to come from Japan. 

Apparently the unit itself is around £1800 plus labour. 

Share this post


Link to post
Share on other sites

Found the option to stop the screen changing, its in General called something like Screen Change on/off.

So this week I was doing a long trip and tried to use the Sat Nav but it forever was placing me in the wrong place, so I have a bad feeling the Sat Nav is suffering the same issues mentioned, sadly I am not on an extended warranty.  I am going to look for this recalibration because it is working but the receiver is putting me in the wrong starting position, fingers and legs crossed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 205 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old