Sign in to follow this  
Ash1388

Slightly high idle

Recommended Posts

U got a 2000 is200se and just wondered if anyone has any ideas what could cause a high idle on these? Its ticking over just over 2000rpm and does sound a bit high to be honest 

Any info will be awesome 

Share this post


Link to post
Share on other sites

Is this even after it has got upto normal operating temp? If so it could be an un-metered Air leak, as in a leak after the air flow sensor and the ecu can’t control it. Spraying some volatile spray ( ie EasyStart) around any suspect hoses/connections while the engine is running may indicate the location as The revs will increase when the spray gets entrained. Obs do this at your own risk! 

Share this post


Link to post
Share on other sites

Thanks for your reply, it's as soon as I start it then when it gets up to temp it will settle down a bit 

Share this post


Link to post
Share on other sites

1500 rpm is normal when cold, around 700 when hot. Has your Battery been disconnected, somethings it takes a while for it to learn the idle speeds and ideally needs to be driven, with stop start driving to learn quickly.

Otherwise your throttle body may be in need of a clean.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this