Do Not Sell My Personal Information Jump to content


Need Help


chrisis200
 Share

Recommended Posts

Just got it over a week ago, it's 99 IS200 Sport, 85k on clock, not been badly treated I know the previous owner. I gave it a little boot in 1st and something I assume (I'm told throttle) got stuck, even when i tried later in second it got stuck again. I had to brake very badly nearly hitting cars on the first day. I turned the engine off and into neutral when I turned it on again the revs went upto the limiter, tested the accelerator would not stop, hit the brakes, clutch, it kept reving insane, as u can understand this had me a little nervous about booting it ever again, I'm taking it for a service soon. Any ideas what I can tell them to look out for?

My friend also poped the hood to look at the engine(sorry I'm really not technical) and he send he had to over wind a spring on the accelerator cable to fix it.

Since then it's done it twice more but after restarting the engine 2 or 3 times it fixes itself, still I dare not drive it now.. Please help..

Driving slow and at 2k revs it's fine, but if I wanted that I would of kept my old slow car :unsure:

Link to comment
Share on other sites


My friend also poped the hood to look at the engine(sorry I'm really not technical) and he send he had to over wind a spring on the accelerator cable to fix it.

:unsure:

put the spring back, imediatley you will damage the stepper motor in the throttle housing otherwise.

regarding the sticking accelerator......pull the drivers foot mat back, its caught under the accelerator

Edited by Monster-Mat
Link to comment
Share on other sites

Have you checked that the throttle pedal is not getting stuck under the drivers floor mat. It has happened to others on here.

Like Zee says it could be a sticky throttle cable but strange that it only happens on wide throttle openings. Could be a problem with the Electronic Throttle Control (ETC), you could try an ECU re-set.

Beat me to it Mat :D

Edited by MacRS200
Link to comment
Share on other sites

Have you checked that the throttle pedal is not getting stuck under the drivers floor mat. It has happened to others on here.

Like Zee says it could be a sticky throttle cable but strange that it only happens on wide throttle openings. Could be a problem with the Electronic Throttle Control (ETC), you could try an ECU re-set.

Beat me to it Mat :D

Thanks for the help guys will get on it right away, should have sum pics up soon as I've put sum TSW 19's on.

:offtopic: I have the classic problem with the CD player as well, apparently theirs a fair few CD's stuck in there but I can't even wiggle anythin around in there as it's locked up :crybaby: but i ran the search topic on here I have a few more ideas to try..thanks again all

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership