Do Not Sell My Personal Information Jump to content


Car Back At Dealer After Four Days


Recommended Posts

Hi

Well, I collected the car last Saturday and all was fine for 3 days. Then on the fourth day the dashboard lit up like a Christmas tree! :crying:

The RAC was dutifully called and found a fault in one of the O2 sensors. He was unsure why this would light up the dash as it did, no surprise there then! Dealer arrived with replacement car, not the same but a Lexus, and mine goes off to Glasgow last thing Wednesday. I said I would collect Sat all being well as I have appointment in the area anyway, but they should call and let me know the score and progress.

No calls so i called today at 3.30 to find that they only got to the car late on Thursday and and he would call back. Well he did and as of end of work today could only tell me what i told them ( wrote down what the rac mans comp had said ) when they collected it. Sounds like the car has not been looked at till I called! Maybe wrong but....... :whistling:

Would a faulty O2 sensor cause the VSC warning and some other things to light up?

No angry ( YET!! ), just frustrated.

Rant off :D

Cheers

Greig :crybaby:

Link to comment
Share on other sites



hey mate the 02 sensor fault will cause all the lights to come on, i had the same problem a few months back, give them a kick up the ***** its an easy job to do unless, they are waiting for the part to arrivve maybe (not giving them an excuse honest) but hope they sort it soon for you mate.

Link to comment
Share on other sites

VSA is Vehicle Service Agreement. So not related. O2 sensor is analysing the oxygen in the exhaust.

It's bad that it's happened when the car is so new and thy haven't tried to sort it straight away.

I know what a VSA is and you're correct it's not related. :D :D

Ive edited the post as I meant VSC. I found another post with the same things related to O2 sensor.

The guy at the garage seemed unconcerned, I will see if they have better atitude in the morning when I am accross the desk. :D

Greig

Link to comment
Share on other sites


hey mate the 02 sensor fault will cause all the lights to come on, i had the same problem a few months back, give them a kick up the ***** its an easy job to do unless, they are waiting for the part to arrivve maybe (not giving them an excuse honest) but hope they sort it soon for you mate.

Hello and thanks for that.

They may have to wait on the part, so not sure. Tomorrow would be a miracle. More likely next week. Never mind.

Thanks, I hope they sort it soon too, as I love the car!

Greig :D

Link to comment
Share on other sites

hey mate the 02 sensor fault will cause all the lights to come on, i had the same problem a few months back, give them a kick up the ***** its an easy job to do unless, they are waiting for the part to arrivve maybe (not giving them an excuse honest) but hope they sort it soon for you mate.

Hello and thanks for that.

They may have to wait on the part, so not sure. Tomorrow would be a miracle. More likely next week. Never mind.

Thanks, I hope they sort it soon too, as I love the car!

Greig :D

no problem mate i say its an easy job, it is now i know how to do it, on the 300 the sensor connects under the carpet under the drivers seat, i could of cut the carpet to get to it but i didn't know if there were any other cables running underneath the seat and i didnt want to ruin the carpet lol, so took the seat out and pulled the carpet up, so make sure they dont cheat and ruin your carpets!! go armed with a 22mm spanner just incase lol

Link to comment
Share on other sites

speaking about the VSC...

I was driving back home, luckily was few miles away, when suddenly a few warning lights lit up

along with "CHECK VSC" message :angry:

When car is in "Ignition On" mode or engine is running I have VSC message, "Master warning light" (red triangle)

and "Malfunction indicator lamp" on (yellow engine or transmission sign).

According to the manual it could indicate malfunctions in engine control system, throttle or transmission control.

Has anyone of you ever experienced anything like that, or any expert here have any idea what could go wrong?

Would be grateful for help :)

Car is one year old, almost 20k miles on the clock, wanted to do 20k service next month,

regards,

Marcin.

Link to comment
Share on other sites

speaking about the VSC...

I was driving back home, luckily was few miles away, when suddenly a few warning lights lit up

along with "CHECK VSC" message :angry:

When car is in "Ignition On" mode or engine is running I have VSC message, "Master warning light" (red triangle)

and "Malfunction indicator lamp" on (yellow engine or transmission sign).

According to the manual it could indicate malfunctions in engine control system, throttle or transmission control.

Has anyone of you ever experienced anything like that, or any expert here have any idea what could go wrong?

Would be grateful for help :)

Car is one year old, almost 20k miles on the clock, wanted to do 20k service next month,

regards,

Marcin.

oh!! :ohmy:

That's my current problem!!!

Greig

Link to comment
Share on other sites

speaking about the VSC...

I was driving back home, luckily was few miles away, when suddenly a few warning lights lit up

along with "CHECK VSC" message :angry:

When car is in "Ignition On" mode or engine is running I have VSC message, "Master warning light" (red triangle)

and "Malfunction indicator lamp" on (yellow engine or transmission sign).

According to the manual it could indicate malfunctions in engine control system, throttle or transmission control.

Has anyone of you ever experienced anything like that, or any expert here have any idea what could go wrong?

Would be grateful for help :)

Car is one year old, almost 20k miles on the clock, wanted to do 20k service next month,

regards,

Marcin.

sounds like you could have the same problem, plug some diagnostics in and it will tell what the fault is.

Link to comment
Share on other sites

go armed with a 22mm spanner just incase lol

:lol::lol: You may be right! Ill pack the whole toolkit in case! :D

Thanks,

Greig

just hide the stanley blades and velcro and use the other tools to get the seat out!

Ah man of experience! :D

Link to comment
Share on other sites

oh!! :ohmy:

That's my current problem!!!

Greig

oh man what a relief!

now when we share same problem it tastes different! much better... I would say :whistling:

wish you quick fix,

cheers!

Martin1978

You too mate. Get it along to them and get it sorted. Seems it's not the end of the world! :)

What a useful place this is! :D

Greig

Link to comment
Share on other sites

speaking about the VSC...

I was driving back home, luckily was few miles away, when suddenly a few warning lights lit up

along with "CHECK VSC" message :angry:

When car is in "Ignition On" mode or engine is running I have VSC message, "Master warning light" (red triangle)

and "Malfunction indicator lamp" on (yellow engine or transmission sign).

According to the manual it could indicate malfunctions in engine control system, throttle or transmission control.

Has anyone of you ever experienced anything like that, or any expert here have any idea what could go wrong?

Would be grateful for help :)

Car is one year old, almost 20k miles on the clock, wanted to do 20k service next month,

regards,

Marcin.

Hi,

I had similar problems with my car, Finally got it sorted under warrenty after trying 3 new sensors it turned out to be the control unit.

The reason tried 3 sensors was the "CHECK VSC" message would reappear after about 20/30 miles of driving.

hope this helps

Link to comment
Share on other sites

Hello

Well in a surprise move the car was returned to me today!

They called this morning and said that after the last call they finished the "diagnostics" to tie down the fault and had a sensor sent by overnight curior. Fitted this morning. :) So all is well with the world again and Im happy.

This has also saved the wear and tear on my 22mm spanner that I had prepared just in case.

Went the long way home :blush: and no problem!

Greig

Link to comment
Share on other sites

Hello

Well in a surprise move the car was returned to me today!

They called this morning and said that after the last call they finished the "diagnostics" to tie down the fault and had a sensor sent by overnight curior. Fitted this morning. :) So all is well with the world again and Im happy.

This has also saved the wear and tear on my 22mm spanner that I had prepared just in case.

Went the long way home :blush: and no problem!

Greig

good news, glad its all sorted :D

Link to comment
Share on other sites

Hi

Yes me too and glad it did not end up as a saga!

Greig

Glad to hear that!

I will do my hopefully just before Christmas, I do not have time to deal with it now,

car will seat it my garrage anyway - sort of punishment for my "beloved" Lexus :angry:

Marcin.

Link to comment
Share on other sites

Hi guys, good to here you got yours sorted Greig.

Unfortunately coming home tonight my dashboard lit up with the same "Check VSC"

Thankfully i managed to get home safely, didn't really notice any problems driving the car while the warning lights were on.

I too am in Glasgow, just wanted to ask how good they were and how long did they have the car for?

Tomorrow is a Saturday and think the Service dep is closed, will the other staff be able to help? I dont wanna sit all weekend with the car sitting in the drive, like Martin, would rather get this sorted before Christmas.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership