N-iGMA

Dash Clock Light

Recommended Posts

Hi guys,

I had my new Headunit fitted in this weekend and ever since I noticed that the Dash Clock's Backlight stays on even after turning the car off or locking the car.

I'm sure this isn't normal but I'm not too sure as I never took much notice of this previously.

Any assistance would be greatly appreciated.

Cheers,

Sunil Kerai

Lexus IS200 Sport | TTE Front Bumper, TRD Side Skirts TTE Rear Skirt | 6000K HID Lights | LED Number Plate Lights | LED Interior Lights

W.I.P: Kenwood DNX5220 + KCA BT200 | Kenwood KAC 9102D Mono Amp | 10" Kicker Solobaric in Custom Kicker Box

Share this post


Link to post
Share on other sites

nah that shouldnt happen mate, as far as i remember the backlight comes on as soon as you turn the key to the first click, regardless of if you turn lights on or not, but definitely goes off when you take key out, havent a clue what would make it stay on tho

Share this post


Link to post
Share on other sites

sounds like youve got a permantant 12v to the lighting signal. prob the dimming signal on the stereo wires,

re-check the wiring

Share this post


Link to post
Share on other sites

Presumably you removed the a/c controls and the connectors from this unit as part of removing the old head unit ? If so, might you perhaps have accidentally damaged/dislodged some of the wiring ? The clock light will be powered via this a/c control connector.

Share this post


Link to post
Share on other sites
Presumably you removed the a/c controls and the connectors from this unit as part of removing the old head unit ? If so, might you perhaps have accidentally damaged/dislodged some of the wiring ? The clock light will be powered via this a/c control connector.

Thanks guys

Share this post


Link to post
Share on other sites

hi did you solve this problem? I have the same issue, and it also started at the same time as changing my headunit?

Share this post


Link to post
Share on other sites

I have a problem where the clock has stopped working, completely dead, the LED in the heater dials don't come on, and the mirrors won't fold. Is this all a coincidence?

Share this post


Link to post
Share on other sites

Did they all work before?could possibly be a blown fuse,worth checking to see if they are all ok

Share this post


Link to post
Share on other sites

I've checked all the fuses

Share this post


Link to post
Share on other sites

BUMP I have the exact same problem..

 

Battery dead after 2-3 days, took light bulbs out of clock and still dies...

 

Any Help?

 

Happened as soon as i installed a Ebay Sony Stereo.

Share this post


Link to post
Share on other sites

I have read on a post here that:

"When taking the stock unit off you are breaking the circuit between clock, c-lighter n sat-nav if u got one which will mean they r running on 12v constant n not ign. In that case u will have to take ur stock unit apart and connect the circuit board leaving it in the glove box connected to the original iso cable in order to have the circuit running. My Battery was flat overnight lol."

 

Am i right in saying that simply removing the fuse for the Cig Lighter will stop its constant 12v and keep the Battery alive for much longer?

 

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 218 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old