Do Not Sell My Personal Information Jump to content


Help Loss Of Some Electrics


Recommended Posts

Hi all hope someone can help, I have a 2001 RX300 Mk1. whilst changing the boot interior light bulb, something appears to have blown and left me with no remote locking, no headlights, no radio, no computer display. there may be more missing but I don't know yet.

Does anyone have any ideas what has gone and what I need to do to fix it.

Any hel appreciated

Link to comment
Share on other sites

Hi all hope someone can help, I have a 2001 RX300 Mk1. whilst changing the boot interior light bulb, something appears to have blown and left me with no remote locking, no headlights, no radio, no computer display. there may be more missing but I don't know yet.

Does anyone have any ideas what has gone and what I need to do to fix it.

Any hel appreciated

Check the fuse in the engine bay you have may have shorted the lot whilst changing the boot bulb and it may still be shorting out touching the back plate of the light.

Hth

Eddie

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...