Do Not Sell My Personal Information Jump to content


Lexus Ls400


lonecarper
 Share

Recommended Posts

Hi,

I have just purchased a 1995 LS400 in Venetian Blue which seems to be a wonderful car in many respects. It has f/s/h and has a few extras such as an L inscribed across each exhaust tailpipe. One thing that is a bit of a problem is that yesterday, both the speedometer ans rev counter needles stopped working. No sign of any wavering or anything, just failed to register. Everything else, i.e. all the gauges etc. work fine so I imagine it is a cable loose or something of that nature. If anyone has any ideas what may have caused this and has any info on how to get thenm working again, I would be very grateful. Thanks, Terry.

Link to comment
Share on other sites

Hi,

I have just purchased a 1995 LS400 in Venetian Blue which seems to be a wonderful car in many respects. It has f/s/h and has a few extras such as an L inscribed across each exhaust tailpipe. One thing that is a bit of a problem is that yesterday, both the speedometer ans rev counter needles stopped working. No sign of any wavering or anything, just failed to register. Everything else, i.e. all the gauges etc. work fine so I imagine it is a cable loose or something of that nature. If anyone has any ideas what may have caused this and has any info on how to get thenm working again, I would be very grateful. Thanks, Terry.

It seems a sharp tap on the top of the dashboard was all that was needed!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership