stormchaser

Members
  • Content Count

    447
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by stormchaser

  1. I’m yet to experience this on my 2011 at 99K. I’ll get them to have a look at it’s oil change/MOT time in October. Sent from my iPhone using Tapatalk
  2. I’m quite slim though Phil and the seat is almost at it’s full travel on the runners. My legs aren’t that bent up and I have it reclined at quite an angle with the steering wheel adjusted quite low. It’s very comfortable like this. I do agree that getting out isn’t the simplest of things as the seat is back behind the B pillar haha. It’s a good job I don’t have rear seat passengers. Sent from my iPhone using Tapatalk
  3. I have a 2011 and don’t find it noisy on any surface. I’ve recently changed all 4 tyres from the original nasty Goodyear’s to Kumhos so now travels in silence. Any passing vehicles on the opposite side I don’t hear. Sent from my iPhone using Tapatalk
  4. Why are the mirror controls over complicated? I find them very basic and easy. Sent from my iPhone using Tapatalk
  5. I have the SE L Premier which has all that and more but I don’t know what the facelift equivalent is. Sorry not much help to you. Sent from my iPhone using Tapatalk
  6. I’m 6’4” and don’t have no trouble at all and the seat isn’t fully back. Sent from my iPhone using Tapatalk
  7. Sounds rubbish to me. I’ve heard mine once in it’s 7 year life. Nothing and no one goes in the back of my CT. Sent from my iPhone using Tapatalk
  8. Hi Yes it’s possible to to do no problem. You have to remove the bumper first to gain access. Then it’s a simple swap over. Sent from my iPhone using Tapatalk
  9. Agree about Audi,s etc. My Octavia tdi threw a rod at 70K. I had it from new and was serviced at the right intervals right up until it happened. It was a well known fault with that year 1.9 tdi but Skoda never done a thing about it. The way I look at hybrids is that generally the engine doesn’t equate to the cars total mileage due to the fact that you are doing a lot of mileage on electric only with no engine running. Obviously different if you do a lot of motorway miles all the time. What I can’t understand is why in the US they have so many problems with the CT when none is recorded here. The same goes for the Prius there too with the same engine. Sent from my iPhone using Tapatalk
  10. I don’t know I’ve never been in that situation of a flat battery. I was just saying how to select neutral should you need to. Sent from my iPhone using Tapatalk
  11. It’s totally pointless changing the oil before 10K. I let mine go 15K once before it was changed and it was still a clear gold colour then. These engines don’t get stressed because of its a hybrid and not always running like a normal engine. My 2011 hasn’t used any oil at all between services and now on 94K. I have read on US forms that some have used 15/30 oil which has cured a lot of consumption. It’s still within the correct grades for the engine. Sent from my iPhone using Tapatalk
  12. As said check the water for soapy feeling. Could be the tailgate seal or even the tailgate striker needing adjustment as it may not be closing tight enough. It won’t be the rear light units as they are bolted on the outside of the body. Update us with the result [emoji1360] Sent from my iPhone using Tapatalk
  13. Welcome and what a beauty [emoji1360] The best colour too! I came from a Suzuki Swift Sport as that suspension was hard but it certainly drove well. I love mine and yes the suspension is firm but not uncomfortable. Just love the Lexus luxury. Sent from my iPhone using Tapatalk
  14. Any update to this? Sent from my iPhone using Tapatalk
  15. Strange. My 2011 has never suffered from misting unlike my previous Skoda Octavia which was more damp inside than out. Sent from my iPhone using Tapatalk
  16. You can shift into neutral on the CT. I always do if I want to roll it out of the garage to do something. Without pressing the Brake press the power button twice to ignition on and select neutral. I’ve left mine once for a month and it was fine. It’s a 2011 with an original battery. Sent from my iPhone using Tapatalk
  17. Mines on 94K and never uses any oil in between 10K services. Sent from my iPhone using Tapatalk
  18. EGR and pipes. Done mine 2 years ago with carb cleaner. It’s never come back. Sent from my iPhone using Tapatalk
  19. It’s a simple plug and play set up. Sent from my iPhone using Tapatalk
  20. I have a 2011 SE L Premier and yes it’s harsh but compared to my previous 2015 Suzuki Swift Sport the CT is soft. I drove a facelift model and found absolutely no difference at all. I don’t want to go down The aftermarket route as I’ve had enough of that from previous cars. I’m quite happy with it as it is. Sent from my iPhone using Tapatalk
  21. I use Redex. £4 a bottle in Tesco. With the carb cleaner I just completely soaked everything on the EGR. Sprayed it on all parts. Sent from my iPhone using Tapatalk
  22. Has been known that the drop links can make this noise. Sent from my iPhone using Tapatalk
  23. I did give it a quick squirt with carb cleaner in the EGR and pipe. There were no error codes at all. To this day it hasn’t done it again. Monthly I give it a shot of fuel injector cleaner which makes a difference. Sent from my iPhone using Tapatalk
  24. When they’re set to Auto they stay on when you switch the power switch off but they will go out when you open the drivers door. That’s what mine does. Sent from my iPhone using Tapatalk
  25. You could try turning the interior motion sensor off first to see if that stops the alarm going off. Sent from my iPhone using Tapatalk