Recommended Posts

I have a new CT200 only done about 1200 miles.

When I put my foot on the brake at low speeds it clicks

quite loudly any ideas

 

Share this post


Link to post
Share on other sites
 

Where is the click coming from? 

Share this post


Link to post
Share on other sites

I have this on my MY17 CT. Only just noticed it before your post. I think it might be the regen system being activated as the brake pedal only needs to the pressed lightly. The car is booked in for it 2 year old service at Cambridge so will ask about it then and report back. 

Share this post


Link to post
Share on other sites

This was a common issue with the Gen3 Prius, the pad retaining clips would lose their spring tension over time and move in the calliper. not dangerous, just irritating.

When you have your pads done just change the retaining clips, that should stop it

Share this post


Link to post
Share on other sites

I have a possibly similar noise on my 2018 CT, currently on 8k miles.  It's like a light cracking noise when braking at very low speeds.  

I've read some worrying stuff about similar noises being knackered driveshafts (!) on Prius Gen 3 models, but also about the brake retainer mentioned above.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.