Recommended Posts

Drivers side yes but oddly I think the Jaguar engines (at least the Ford units) were on the same side too.

  • Like 1

Share this post


Link to post
Share on other sites
 

I am a bit behind with this thread but I once triggered the Check VSC after filling the car with fuel and adding some Redex to the mix. Once the tank was empty and refilled, the light went out pretty quickly

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, SpeedyGee said:

Drivers side yes but oddly I think the Jaguar engines (at least the Ford units) were on the same side too.

Thanks for taking the time (and everyone that's contributed)  At least I know my bank 1 upstream sensor is OK for a bit!  And I think the downstream sensor is a tad cheaper.

Share this post


Link to post
Share on other sites

I’ll keep looking at this thread until you get this sorted Phil - as I said before I have the same problem but the emissions are spot on so I won’t start buying any parts just yet.

Share this post


Link to post
Share on other sites
1 hour ago, cruisermark said:

I’ll keep looking at this thread until you get this sorted Phil - as I said before I have the same problem but the emissions are spot on so I won’t start buying any parts just yet.

As far as I'm aware the bank 1 sensor is fairly straightforward (I hope) bank 2 means a massive amount of work removing the passenger seat, how ridiculous.  I see on some US forums they simply cut and join the wires making sure they're water tight saving 2 hours or more of back aching work. I'm going to make sure it's definitely the sensor before attempting it.

Share this post


Link to post
Share on other sites

Hi all.

Sorry to throw a spanner in the works but are you sure it is a sensor from the engine as i had the VSC come on in my IS250 and the garage after a lot off searching with lap top and 2 technicians driving the car found it was a sensor in the car nothing to do with engine /  exhaust at all and it cost £ 950.00 pounds including labour over £600 for sensor lucky i had the warranty just worth looking deeper before parting with money.:sad:

65mike.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now