Do Not Sell My Personal Information Jump to content


Experience with GS450h P2792 code


Gentleman
 Share

Recommended Posts

Hello all,

previously came to this forum when my GS450h was throwing codes P0420 and P0430. Catalytic converter issues diagnosed and few weeks later, 2 Cats were replaced.

Took the car for the first proper spin on a return journey from London to Liverpool yesterday and the car ran fine (500 miles appox). In my mind, the issue is now resolved and all is good. 

This morning during school run, Check Hybrid light came on, check VSC, Check ECB. However, the car behaved differently this time. It more or less stopped but thankfully I was in traffic so no drama caused. I shifted into P, started the car again and it worked but the car felt heavier and I noticed the hybrid did not work. 

On my way back, I started the car and although the Check hybrid was on, the hybrid worked and then few minutes later, it kind of lost power. Restarted the car and it worked with no hybrid power.

I have just plugged in my OBDII and it says P2792. Meant to be driving to work tomorrow, about 40 miles round trip and I'll appreciate your words of wisdom, advice or signpost to a garage in the London/Essex area. Thank you.

 

 8f3e5614-d16c-4fcc-a8d5-1454e401e437.jfif

Link to comment
Share on other sites


As I planned to take this car to work tomorrow, I thought I'll take it for a spin tonight to see if it's doable tomorrow. The car did a 10 miles return journey fine. I noticed the cruise control did not work, it'll only speed up to 80mph but not past that mark. 

The hybrid really is the thing that makes the car fast and I quickly realised the confidence you get from the feeling that you can join a motorway quickly etc is gone as the car is just slower to respond.

I think the car will be fine for work tomorrow but I'll appreciate some support or recommendation from anyone who has had this experience or knows where to definitely fix this in Essex/London area. 

Thanks

Link to comment
Share on other sites

Car drove fine to work today and for some reason, the hybrid worked. It is like nothing happened apart from the check hybrid message on the dashboard. 

Planning to take it to the garage next week to see what they say. My concern is that the garage is not a lexus specialist and I have realised it is always good to use someone who knows about these cars.  So again, any recommendations around London or Essex area is welcome.

Link to comment
Share on other sites



Hmm....

It may have saved a bit of time if the topic title had the correct error code number - you wrote P2792 but your photo shows P2797  :whistling: 

Anyway, a quick Googling of P2797 comes up with a few things, the first one below from an American forum and the second one from this very forum here:

https://www.clublexus.com/forums/hybrid-technology/853851-p2797-with-subcode-865-on-2008-gs-450h.html

 

 

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

I just want to add on part of cruise control that it may be locked to that speed. Have same on both cruise control and radar that max speed is 115 km/h with any adjustment in between 0 - this sounds to be around same of your max setting. Law regulation I guess in my case (import), possibly yours as well.

  • Thanks 1
Link to comment
Share on other sites

  • 3 weeks later...

Just wanted to keep everyone updated as to what has happened so far.

The issue with the car is indeed the transmission oil pump according so thank you everyone for your suggestions. I have made a lot of effort to find someone who can help with the cheaper fix that is known to work by replacing the worn bearing on the pump but no luck. So, it looks like a brand new one it is.

Lexus have quoted £1900 to do the job and a 2 weeks wait for part to arrive!!!!!! 

 

Link to comment
Share on other sites

  • 3 weeks later...

I now have the car back from Lexus and it is working well. For others having the same issues, transmission oil pump change is what has resolved mine. Annoying and costly, but once you get back in the GS450h, your smile will be back in no time 🙂

 

Again, grateful for this community and the contribution of it's members.

  • Like 2
Link to comment
Share on other sites

12 minutes ago, Gentleman said:

I now have the car back from Lexus and it is working well. For others having the same issues, transmission oil pump change is what has resolved mine. Annoying and costly, but once you get back in the GS450h, your smile will be back in no time 🙂

 

Again, grateful for this community and the contribution of it's members.

Thats great news 🙂 glad you have your ride back to enjoy even more now 🙂

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership