Do Not Sell My Personal Information Jump to content


Engine Check Light


r34liner
 Share

Recommended Posts

hi all

my lexus is300 (scarfaces old ride) threw a engine check light,

code p0141 o2 pre heater circuit, bank 1 sensor 2, im guessing that its the sensor near cat?

i was told it had a 02 simulator already installed before full decat 2 weeks ago, didnt throw check engine light until i had done 1200 miles,

any replys or how to fix this would be greatly appreciated as its costing me a fortune in petrol!!! lol

louis

Link to comment
Share on other sites


hi all

my lexus is300 (scarfaces old ride) threw a engine check light,

code p0141 o2 pre heater circuit, bank 1 sensor 2, im guessing that its the sensor near cat?

i was told it had a 02 simulator already installed before full decat 2 weeks ago, didnt throw check engine light until i had done 1200 miles,

any replys or how to fix this would be greatly appreciated as its costing me a fortune in petrol!!! lol

louis

Have you tried just doing an ecu reset?

Link to comment
Share on other sites



In that case then mate, I am afraid you will get the CEL light come on from time to time. I've got a full decat system on my IS as has DazaW and we both still suffer from it. We've also got O2 sensors fitted but unfortunately they are still not a permanent solution. Something to do with Lexus using different sensors.

Nobody to date has been able to find a permanent solution for this problem. Its still a case of just resetting the ECU when it comes on which is a pain in the arse but for now we have to put up with it.

Link to comment
Share on other sites

I find that my CEL comes on more the hotter the weather is or after long motorway journeys..

Does it come straight back on after you reset? Maybe you've damaged a sensor? Or not refitted correctly?

But as I say unfortunatley it will come on if there's no cats fitted.

Link to comment
Share on other sites

i would just remove bulb from dash, but as soon as light came on car runs like a bag of ****, missfiring and stinking of fuel as ecu must go into some sort of safe mode and throw far to much fuel in, tell truth ****** off with car at minute,

Link to comment
Share on other sites

yeah could leave it ticking over on my drive and cel would be on, maybe get sensors tested to make sure

yeah just changed plugs, the ignition seems fine just overfuelling causing the car to miss and stumble on low throttle, is sensor 2 bank 1 the cat sensor

Link to comment
Share on other sites

yeah could leave it ticking over on my drive and cel would be on, maybe get sensors tested to make sure

yeah just changed plugs, the ignition seems fine just overfuelling causing the car to miss and stumble on low throttle, is sensor 2 bank 1 the cat sensor

bank 1 sensor 2 is one of the sensors on the manifold before the cats.

The error produced is a problem with the heater rather than the O2 sensor itself. It checks this by measuring the current going through the circuit. If you are using an O2 simulator then it needs to be a 4 wire one with the heater circuit having the same resistance and the original sensor.

You can always use a simulator just for the O2 circuit (two wires) and connect the other two wires to the original sensor.

Link to comment
Share on other sites

Hello mate .......... Im sure the 02 simulator is only good for the pre-cats ............ and not for when you take out the main cat. :unsure:

Didn't TDi also make a solution for the main cat, as like on Daza's car ... he had the same prolem when he took out the main cat!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership