Mitcheyfex

Greetings from a new member -Just bought a 2006 Is250 SE Mark Levinson, did I pay too much?

Recommended Posts

Hi! I'm new here and new to lexus in general but I fell in love with one the other day and I've not long just got back from London with my new car - really impressed!

I sold my 3 series and managed to pick up a 2006 Lexus IS250 Mark Levinson on 143k miles with full stamped Lexus Service History, mechanically the car is a pleasure.

For some reason though, the screen doesn't come on and lights aren't illuminated on the central console, looking online I can see this is a common issue, and can be quite costly! I paid £1200 which is great but it would be nice to have the centre system working, the guy I bought the car off has bought fuses so I'm assuming the fuses are okay, any idea what this could be? Radio still works, I can still see the clock etc, the bottom half of the console seems to work fine it's just the screen and a few buttons not illuminating.

Any ideas? Thanks for reading and glad to.be here!

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hello Mitch and welcome to the LOC.

Posting at 1.00 am either means the excitement of a new car or the worry of a problem must have kept you awake. At the price you paid I would have slept soundly even with the problem 😀

Not come across the problem you have got personally, I know the cause on the LS400 but will see what I can find out for you. Worst scenario is getting a good working unit from a breaker, there again there are a lot of fuses to check and you may be lucky if one has been missed.

Pretty sure other owners will chip in with suggestions.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hello Mitch and welcome to the LOC.

Posting at 1.00 am either means the excitement of a new car or the worry of a problem must have kept you awake. At the price you paid I would have slept soundly even with the problem 😀

Not come across the problem you have got personally, I know the cause on the LS400 but will see what I can find out for you. Worst scenario is getting a good working unit from a breaker, there again there are a lot of fuses to check and you may be lucky if one has been missed.

Pretty sure other owners will chip in with suggestions.

I found this, fuses to check are Nos. 4 and 12 in the passenger fuse box.

https://knigaproavto(blocked word)/shemy/en/lexus/is/746-2006-2013-lexus-is-250-300-350-220d-fuse-box-diagram.html

  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, steve2006 said:

Hello Mitch and welcome to the LOC.

Posting at 1.00 am either means the excitement of a new car or the worry of a problem must have kept you awake. At the price you paid I would have slept soundly even with the problem 😀

Not come across the problem you have got personally, I know the cause on the LS400 but will see what I can find out for you. Worst scenario is getting a good working unit from a breaker, there again there are a lot of fuses to check and you may be lucky if one has been missed.

Pretty sure other owners will chip in with suggestions.

I found this, fuses to check are Nos. 4 and 12 in the passenger fuse box.

https://knigaproavto(blocked word)/shemy/en/lexus/is/746-2006-2013-lexus-is-250-300-350-220d-fuse-box-diagram.html

Hi Steve!

Thanks for the warm welcome, what a brilliant start I feel at home already.

I can assure you it was the excitement keeping me awake, and it's reassuring to hear that you feel the price I paid was a good one despite the issue I mentioned.

Really handy useful information I'll check them fuses tomorrow (Another reason not to sleep) 

It's weird, no air con, no heating, and pretty much none of them top buttons work, however the security light still flashes and hazards still work on the unit along with the radio controls.

Any other suggestions from other members are welcomed and ill be sure to try yours tomorrow and post my outcome.

Also, I wondered what the MM means in my vehicle information the car is listed as a Lexus 2006 IS250 MM, would that just be the higher spec version of the car? 

 

Literally no lights on the dash and looking through the history this was someone's 'Baby' and it has been well taken care of! It's a joy to drive and I feel I'm getting decent MPG!

Thanks again for the warm welcome and I hope to hear from some of the other members soon on this thread.

 

😀

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.