Mitcheyfex

Greetings from a new member -Just bought a 2006 Is250 SE Mark Levinson, did I pay too much?

Recommended Posts

Hi! I'm new here and new to lexus in general but I fell in love with one the other day and I've not long just got back from London with my new car - really impressed!

I sold my 3 series and managed to pick up a 2006 Lexus IS250 Mark Levinson on 143k miles with full stamped Lexus Service History, mechanically the car is a pleasure.

For some reason though, the screen doesn't come on and lights aren't illuminated on the central console, looking online I can see this is a common issue, and can be quite costly! I paid £1200 which is great but it would be nice to have the centre system working, the guy I bought the car off has bought fuses so I'm assuming the fuses are okay, any idea what this could be? Radio still works, I can still see the clock etc, the bottom half of the console seems to work fine it's just the screen and a few buttons not illuminating.

Any ideas? Thanks for reading and glad to.be here!

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hello Mitch and welcome to the LOC.

Posting at 1.00 am either means the excitement of a new car or the worry of a problem must have kept you awake. At the price you paid I would have slept soundly even with the problem 😀

Not come across the problem you have got personally, I know the cause on the LS400 but will see what I can find out for you. Worst scenario is getting a good working unit from a breaker, there again there are a lot of fuses to check and you may be lucky if one has been missed.

Pretty sure other owners will chip in with suggestions.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hello Mitch and welcome to the LOC.

Posting at 1.00 am either means the excitement of a new car or the worry of a problem must have kept you awake. At the price you paid I would have slept soundly even with the problem 😀

Not come across the problem you have got personally, I know the cause on the LS400 but will see what I can find out for you. Worst scenario is getting a good working unit from a breaker, there again there are a lot of fuses to check and you may be lucky if one has been missed.

Pretty sure other owners will chip in with suggestions.

I found this, fuses to check are Nos. 4 and 12 in the passenger fuse box.

https://knigaproavto(blocked word)/shemy/en/lexus/is/746-2006-2013-lexus-is-250-300-350-220d-fuse-box-diagram.html

  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, steve2006 said:

Hello Mitch and welcome to the LOC.

Posting at 1.00 am either means the excitement of a new car or the worry of a problem must have kept you awake. At the price you paid I would have slept soundly even with the problem 😀

Not come across the problem you have got personally, I know the cause on the LS400 but will see what I can find out for you. Worst scenario is getting a good working unit from a breaker, there again there are a lot of fuses to check and you may be lucky if one has been missed.

Pretty sure other owners will chip in with suggestions.

I found this, fuses to check are Nos. 4 and 12 in the passenger fuse box.

https://knigaproavto(blocked word)/shemy/en/lexus/is/746-2006-2013-lexus-is-250-300-350-220d-fuse-box-diagram.html

Hi Steve!

Thanks for the warm welcome, what a brilliant start I feel at home already.

I can assure you it was the excitement keeping me awake, and it's reassuring to hear that you feel the price I paid was a good one despite the issue I mentioned.

Really handy useful information I'll check them fuses tomorrow (Another reason not to sleep) 

It's weird, no air con, no heating, and pretty much none of them top buttons work, however the security light still flashes and hazards still work on the unit along with the radio controls.

Any other suggestions from other members are welcomed and ill be sure to try yours tomorrow and post my outcome.

Also, I wondered what the MM means in my vehicle information the car is listed as a Lexus 2006 IS250 MM, would that just be the higher spec version of the car? 

 

Literally no lights on the dash and looking through the history this was someone's 'Baby' and it has been well taken care of! It's a joy to drive and I feel I'm getting decent MPG!

Thanks again for the warm welcome and I hope to hear from some of the other members soon on this thread.

 

😀

Share this post


Link to post
Share on other sites

**Update**

 

i have managed to source a second hand Mark Levinson unit, for a decent price as well! £120 + postage which was £10, I checked fuses 4 & 12 as previously recommended by @Steve thanks mate, and sadly no fuses were blown and even after changing them, still no luck. So I went for a second hand Mark Levinson unit, it arrived today, I'm wondering whether to do the replacement myself or pay someone to do it, it's a simple plug and play then I am.anle to do this myself, does anyone have any ideas on the difficulty of this job, or any links to tutorials I can use, or any advice you can throw my way?

 

Thanks,

 

Mitch 

Share this post


Link to post
Share on other sites

What do you have ... Automatic or Manual gearbox?

Gotta start there really. 🙂

Share this post


Link to post
Share on other sites

I'll assume you have an automatic gearbox ... well, they are the best! 🤨

Watch these vids to learn how to remove the radio/cd unit.

If you don't have any get yourself a set of plastic pry tools. You can buy them on Ebay (like this Link ) or probably at your local weekend market. Not expensive and oh so valuable for any trim removal in the future. You really don't want to chew up that dash with screwdriver blades do you? Pay particular attention to how the air con vent at the top is removed. With care it can be an invisible removal. A poor effort (which you can see all too often in for sale ads) will render a nastily brutalised surround.

 

 

Understand exactly how to go about it from the vids. Cover any surrounds with masking tape to avoid any scratching of surfaces. Have some clean sheets to protect other areas and have an old pillow to hand (or similar) as the unit is quite weighty to lift out. You may need a temporary rest point while you unclip all the wiring.

Take photos to refer back to and pay special attention to all the electrical connections.

Good luck.....   and take your time ... no one is marking you for speed 🙂

  • Thanks 1

Share this post


Link to post
Share on other sites
21 minutes ago, normski2 said:

What do you have ... Automatic or Manual gearbox?

Gotta start there really. 🙂

Hi! It's a 6 speed manual.

Share this post


Link to post
Share on other sites

Ah bugger ... hang on a minute!

  • Thanks 1

Share this post


Link to post
Share on other sites
3 minutes ago, normski2 said:

I'll assume you have an automatic gearbox ... well, they are the best! 🤨

Watch these vids to learn how to remove the radio/cd unit.

If you don't have any get yourself a set of plastic pry tools. You can them on Ebay (like this Link ) or probably at your local weekend market. Not expensive and oh so valuable for any trim removal in the future. You really don't want to chew up that dash with screwdriver blades do you? Pay particular attention to how the air con vent at the top is removed. With care it can be an invisible removal. A poor effort (which you can see all too often in for sale ads) will render a nastily brutalised surround.

 

 

Understand exactly how to go about it from the vids. Cover any surrounds with masking tape to avoid any scratching of surfaces. Have some clean sheets to protect other areas and have an old pillow to hand (or similar) as the unit is quite weighty to lift out. You may need a temporary rest point while you unclip all the wiring.

Take photos to refer back to and pay special attention to all the electrical connections.

Good luck.....   and take your time ... no one is marking you for speed 🙂

Thanks for all the info here, interesting read.

 

It has got me somewhat concerned though as my dash seems to already be screwed up from a previous owner not being careful, I also noticed that the surround sound is nothing special, but whether or not this is because I don't have access to the screen or the equaliser I don't know... Could it be a case that due to one of the previous owners not being more careful they could have messed up the surround sound?

Share this post


Link to post
Share on other sites

This is the lower console removal on a manual gearbox jobbee.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Possibly but you will need to access the menus. 

There is a noticeable difference (to my ears anyway) between Stereo and Surround options.

Mine is the facelift 2010 version so maybe things are a little different ... but in all honesty I doubt it

Share this post


Link to post
Share on other sites
2 minutes ago, normski2 said:

Possibly but you will need to access the menus. 

There is a noticeable difference (to my ears anyway) between Stereo and Surround options.

Mine is the facelift 2010 version so maybe things are a little different ... but in all honesty I doubt it

Ahhh I see, So it could just be a cas ethat my car is actually stuck on 'Stereo' I've never seen these menus, so no idea what it is on, but the sound sounds very trebily, but doesn't sound to great on mids and lows.

Thanks for the tutorial, I'll give it a go!

Much appreciated 😃

Share this post


Link to post
Share on other sites

You have a menu for Bass, Mid and Treble settings within as well.

Could just be ...  not set up how you would like it. We all have different listening preferences.

Surround just gives it all bit more space and width and depth.

I have some DVD audio discs and they do sound rather good I must admit.

Share this post


Link to post
Share on other sites
3 minutes ago, normski2 said:

You have a menu for Bass, Mid and Treble settings within as well.

Could just be ...  not set up how you would like it. We all have different listening preferences.

Surround just gives it all bit more space and width and depth.

I have some DVD audio discs and they do sound rather good I must admit.

Nice, I can't wait to try this today and let you know how I get on.

In all fairness,, I was under the impression that the Mark Levinson system came with the ML AMP and SUBWOOFER however my car doesn't have none, maybe newer models only?

I really hope this unit works today and it isn't something to do with the wiring behind the unit, it definetly isn't a fuse.

Share this post


Link to post
Share on other sites

There is a Bass speaker hung under the rear parcel shelf But it's not an earth shaker.

There was never a sub in the boot or owt like that.

MM stands for Multi Media ..... by the way.

Share this post


Link to post
Share on other sites

Quick update on this one,

 

Plugged the new second hand unit in today, and for some reason Map/Voice Display and settings were't working at first and other menus had white vertical lines going through the screen, after playing about with the fuse box I have managed to secure full functionality all apart from the radio for some strange reason, but I am able to still use the radio and aux via the steering wheel controls.

My old radio actually worked fine andis in better cosmetic condition, this came in one whole unit so I'm wondering if there would be a way of seperating the radio from the screen section and using the old radio??

It wasn't set on SURROUND and was indeed on Stereo and you can definetly notice a difference @Normski nevertheless I still found the sound quite underwhelming and wondered if some of the speakers are worn/not working or Mark Levinson systems weren't as good on the 2006 models as oppose to the later models.Might be worth adding in a sub for the lows I wonder if that can be done easily and might make it sound more full bodied?

I'll say it again though, great car. can't see me wanting any other car if I'm honest. 😁

Share this post


Link to post
Share on other sites

Hi Mitch. Just come across your thread. Firstly welcome to the best Lexus forum there is. Wow £1200 for a great car. Cheap. I paid 4X that for my 2007 78k 1 owner ffs car. 

You've mentioned the dash around the radio/nav unit looks damaged. Looks like a previous owner had an issue and had the unit out and possibly forgot one or more of the multi plugs. The ML system is superb. In my current is250 it sounds better than the ML in a 14 plate is300h I had and in the 62 plate RX450h I had (I've only had Lexus cars with ML). 

Are you sure you've got ML? Does your rear shelf have 3 speaker grills and the rear doors 2 speaker grills each and front doors 3 and a centre dash speaker grill?

To test each speaker then you have to ay with the sound stage setting and have the music play from each door individually. 

You could find a car hifi specialist near you to have a look.

You paid £120 for a 2nd hand radio/nav unit? Blimey you struck lucky. They're usually around £400.

You asked if you can swap your original screen for the 2nd hand one. Yes you can. You have to unscrew the bolts on the side of the unit where the bright silver bracket is and separate the 2 halves then swap. There are tutorials on the tube. 

Glad you love your car. They're summat else.

Share this post


Link to post
Share on other sites
2 hours ago, Mr Vlad said:

Hi Mitch. Just come across your thread. Firstly welcome to the best Lexus forum there is. Wow £1200 for a great car. Cheap. I paid 4X that for my 2007 78k 1 owner ffs car. 

You've mentioned the dash around the radio/nav unit looks damaged. Looks like a previous owner had an issue and had the unit out and possibly forgot one or more of the multi plugs. The ML system is superb. In my current is250 it sounds better than the ML in a 14 plate is300h I had and in the 62 plate RX450h I had (I've only had Lexus cars with ML). 

Are you sure you've got ML? Does your rear shelf have 3 speaker grills and the rear doors 2 speaker grills each and front doors 3 and a centre dash speaker grill?

To test each speaker then you have to ay with the sound stage setting and have the music play from each door individually. 

You could find a car hifi specialist near you to have a look.

You paid £120 for a 2nd hand radio/nav unit? Blimey you struck lucky. They're usually around £400.

You asked if you can swap your original screen for the 2nd hand one. Yes you can. You have to unscrew the bolts on the side of the unit where the bright silver bracket is and separate the 2 halves then swap. There are tutorials on the tube. 

Glad you love your car. They're summat else.

Hi @Mr Vladand other viewers,

Thanks for your input and taking the time to view and reply on this thread.

Makes me feel a lot better about the price I paid, for both the car and the stereo, thank you for making my day 😃

"You've mentioned the dash around the radio/nav unit looks damaged. Looks like a previous owner had an issue and had the unit out and possibly forgot one or more of the multi plugs" It does look like this may be the case, I also noticed when removing it that two of the flip-down clips inside the grille were stuck in the open position and not lockable, the dash around the unit does look nasty though, one idea I had was to find some chrome beading and stick around the outline of the unit, of course this come with risks in itself to the dash, but any ideas on neatening this up are also welcomed!

Mine definetly has the 3 speaker grilles in the rear parcel shelf, one main centre one with 2 at the sides, the rear doors have the two speaker grilles as well as a little tweeter grille just by the door release handle, same as the front, I haven't looked but can't remember there being a centre one in the middle front which is noticable, maybe it is there. I'll confirm this later. I have noticed though that it is registered as an MM, however mine doesn't play DVD's etc... so I'm wondering if it is really ML or not?

"To test each speaker then you have to ay with the sound stage setting and have the music play from each door individually."

Funny you should mention this, I actually did this yesterday, the sound coming from the rear passenger is muffled and quite chopy, it kinda sounds like I may have a blown speaker on that side, also, two of the main speakers from the rear also arent working, not sure if the plug for them has just came loose or there is a blow, when I bought the car it had damage to the drivers rear door panel (so there was structrual damage to the rear for sure) Might be worth me checking this out when I replace the door and take the door cards off perhaps, I'd say there are 3 speakers not working to full potenital at most, could this really make that much of a difference and could this be the reason why it does sound rather underwhelming?

I'm lucky that I know someone who works in body repair and painting, so he is going to do the new door for me as well as touch up some of the stone chips around the car and get the paintwork back to its former glory, he is going to do this for me for £200 +paint - So that always helps!

I did pay £120 for a second hand ML nav unit with radio, but as mentioned, the radio section of this doesn't work and there are cosmetic marks on this unit (Which i haven't yet tried to get out, so perhaps the price is about right?)

It really is a shame, because the unit I took out of the car the radio section was working perfect and the screen wasn't, this new one is the other way around, full working screen and air con controls but radio panel and buttons not working.

I'm wondering if it's worth sending my old unit off for repair somewhere, any ideas? The overall condition of my old unit is 10/10 whereas this new unit is more like 6/10.

I've read that the display module goes in these and even sometimes just the screen, I'm not too sure how to diagnose this but all I know is the screen OR the controls didn't work on the old one.

 

Thanks again for taking a look and for your positive comments, I completely agree with this car being something else, I find myself looking for excuses to drive it.

 

Hope everyone is keeping cool in this ridiculous weather.

Share this post


Link to post
Share on other sites

Hi Mitch. The tell tale way to know if you have ML is it'll say Mark Levinson on the lower part of the headunit. Putting a chrome type beading around the headunit sounds a good idea but maybe a silver/grey or black?

Yeah those clips on the dash vents are tricky. At least 2 of mine are knackered. 

Sounds like you probably have a few knackered speakers that'll need replacing. However be aware of the ohmage of the speakers. Not always 4ohm. 

Yes I've seen on utube replacing the touch screen screen. Not expensive to do either. 

I've stated yes you can swap the two parts over separately. Look on the tube about updating none nav radios to android type.

As for sending unit for repair. All I can think of is a hifi specialist and go from there. 

Share this post


Link to post
Share on other sites
40 minutes ago, Mr Vlad said:

Hi Mitch. The tell tale way to know if you have ML is it'll say Mark Levinson on the lower part of the headunit. Putting a chrome type beading around the headunit sounds a good idea but maybe a silver/grey or black?

Yeah those clips on the dash vents are tricky. At least 2 of mine are knackered. 

Sounds like you probably have a few knackered speakers that'll need replacing. However be aware of the ohmage of the speakers. Not always 4ohm. 

Yes I've seen on utube replacing the touch screen screen. Not expensive to do either. 

I've stated yes you can swap the two parts over separately. Look on the tube about updating none nav radios to android type.

As for sending unit for repair. All I can think of is a hifi specialist and go from there. 

Yes, my new and old unit definitely have Mark Levinson written on the lower part of the unit. You have got me thinking about the generalised colour scheme of the interior and I think black or silver is a much better shout to be honest! Thanks for the suggestion, will definitely try this and post my results for other members!

Thing is, it's not the touch screen that has gone but more the whole screen in general (completely blank) doesn't even power up, I read that this could be a display module.

You also mentioned about some of the speaker and mentioned that it isn't always 8 ohms, surely I would need ML replacements in order to achieve the sound which is meant for this car? Or would it be fine just sticking speakers in as long as they fit and have the correct ohmage.

Thanks for all of your help so far @Mr Vlad

Share this post


Link to post
Share on other sites

Yes ML speakers are 3ohm usually which I find strange. Not often for sale in the 2nd hand market. 

I was looking at my car and thought to put a beading around the radio would be one almighty squeeze .

Definitely look on YouTube about the screen and display module. Good info on there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.