Do Not Sell My Personal Information Jump to content


Recommended Posts

Is my starter motor dead ?

Turn the ignition key and all i get is a loud clicking noise. Ignition lights, and head lights etc all fine, in fact have a brand new Battery in it as well !

Any suggesttions before i pay an arm and a leg to have towed away ?

Link to comment
Share on other sites


I have had the Battery checked and it is 100%. Made sure the conncections are good as well. All works, windows. lights etc all fine. I just get the clicking sound that seems to come from somewhere on top of the engine. No idea where starter motor is and if it is even that thats the problem. Its a Gs300 sport mk1 with a 150k on the clock.

Link to comment
Share on other sites

If the clicking is quite and seems to come from the top of the engine then it is probably just the starter relay you can hear in the fusebox.

Sounds like the starter solenoid has stuck. Removing and cleaning may well fix the problem.

Link to comment
Share on other sites


thanks to all for the input. Turns out to be knackered starter motor contacts. Useful tip if this happens to people... turn the ignition key really quickly and in rapid succession (suggested by local Toyota dealer) and this seems to get the thing to splutter into life. Now in for repair and service..... shame they cant turn into a 430 sport while its there !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership