Do Not Sell My Personal Information Jump to content


Track sequence wrong when playing MP3's from USB


Fusspot
 Share

Recommended Posts

I wonder if any other ES owners have this problem, which appears to be audio firmware related.

When selecting an album to play from USB, tracks are played in alphabetic order based on the MP3 tag title name, rather than the MP3 tag track number or the filename order in the album directory. Having tracks played in the wrong sequence is really annoying.

The same USB files used to play correctly in my old IS 300H, based purely on filenames, which contained a track number prefix, e.g. for a given "Artist - Album" folder:

  "01 - First Track.mp3"
  "02 - Second Track.mp3"
  "03 - Third Track.mp3"
  etc.

(the USB folder layout is currently only one deep).

The only way I've found to get tracks to play in the right order, is to edit the MP3 tag title name to contain a numeric prefix to control the sort order, viz:

  "01 - First Track"
  "02 - Second Track"
  "03 - Third Track"
  etc.

but this isn't really acceptable on a number of fronts, not least of which it messes up the audio detail display, as well as voice control selection of tracks.

Checking, my audio software revision is 1000, and elsewhere on this forum (thread Firmware details), I've seen someone has audio revision 1010.

I spoke to Lexus UK tech support today, and they weren't aware of this specific issue.

Has anyone else seen this problem, have another workaround, or has this been fixed in release 1010 (or later)? Is there an audio software release to resolve this issue I can request through my local Lexus dealer?

Link to comment
Share on other sites

Hi Pete,

I can't speak for the ES model but I have the same issue with the audio system in my NX and I believe that the problem exists in the majority, if not all, of the systems in other (recent) models - there are numerous threads about it in the various forums. 

The only way round this was to do as you did, i.e. prefix each track's Title tag with the correct track sequence number but, as you say, this isn't a very user-friendly or graceful solution.

With regards to a software update potentially solving the problem, I wouldn't hold out much hope for that I'm afraid. I recently updated the system in my NX to the very latest software and the problem still exists.

The reason I preferred to play music from USB was that it displayed the album's cover art much more consistently and accurately than when playing via Bluetooth (don't get me started on that damn Gracenote add-on!). Seems like you can't have everything working perfectly.

Just another "quirk" of the Lexus infotainment system I'm afraid ☹️

Link to comment
Share on other sites

Hi, yes it’s the same in my NX too and I used the same solution. I find it especially annoying when my previous GSs worked fine.

First world problem I know, but is it worth raising via the dealer?

 

Link to comment
Share on other sites

Thanks to all for replying. It's some consolation to know I'm not the only one frustrated by this problem, and that you equally came up with the same limited workaround. If it affects the NX, then most likely the UX as well; the recent models it seems.

The car is going in to the local dealer (Inchcape) at the end of next week, to get the firmware updated, but I suspect you're right, in that this won't make any difference.

In which case I will get them to escalate this through their dealership, as much as me contacting Lexus directly.

 

Link to comment
Share on other sites

With my IS and Rx,  I found this to be a Microsoft windows bug, rather than Lexus.  

For windows, you can download a tool called "FAT sorter" .. then re-order the files on your memory stick ... should put them all in alphabetical order.

Link to comment
Share on other sites


11 hours ago, jumbojake said:

With my IS and Rx,  I found this to be a Microsoft windows bug, rather than Lexus.  

For windows, you can download a tool called "FAT sorter" .. then re-order the files on your memory stick ... should put them all in alphabetical order.

Hi, yes I've seen this on other systems. It's not really a Windows bug, it occurs because some systems cannot handle long file names and use the old MSDOS 8.3 filenames instead. These are still applied to filenames, but are not normally visible to the user. With the limited length of the 8.3 filename, they don't always match the order of the long filenames and a program, like the one you suggested, can help get them to match up. I did have this occasionally with my old GS system, for example it would always list the folder that was copied last as the first folder in the list.

Unfortunately I checked and this is not the problem with my NX, it genuinely seems to use the track name to order them. I presume the ES is the same. The only fix I can see is for Lexus to reprogram it to either use the filename or the track number.

Link to comment
Share on other sites

Yes, Spacenase beat me to a reply, and he's right over the folder sequencing. I can also confirm my old IS needed a sorted list of folders / files (FAT32 memory stick), to play album tracks in the correct order. I used to use xcopy or robocopy to copy the files over from hard drive to do this, and had to do a format and full copy each time I added a new album.

But for belt and braces, today I did download and apply "FAT sorter"; it's not solved the problem on the ES. So the only solution for now appears to be to change ALL the MP3 tag title names in each album folder, to provide an alphabetically sorted order, viz:

  "01 - First Track"
  "02 - Second Track"
  "03 - Third Track"
  etc.

The audio firmware fix for this should be, for a given album folder, to use the track number tag rather than track name tag, or if that's missing use the track file name order in the folder. The track name tag should have no bearing on the order tracks are played. The code would need appropriate error checking when parsing each album folder. Some track number tags may be missing, and I've equally seen tag entries of the form 1, 01, 1/12, 01/12, etc.

Lexus really do need to fix this annoying feature.

  • Like 1
Link to comment
Share on other sites

I've just remembered the weirdness of the setup on the GS. By default, it displayed the filename, artist and folder name and sorted by filename (never understood why it could display the artist, but not the track name or the album title). If you then went in to browse by album or artist etc. and selected a track, it would display track title, artist and album title. When it did this, it would then sort by track title. The next time you restarted the system, it would go back to the default display and order.

I think all they've done is replaced the default settings so it shows the tag information rather than the file/folder information. I suspect the track order issue has been around since the Mk4 GS came out, certainly since the facelift in 2016.

Link to comment
Share on other sites

MP3 playback has been poor on Lexus systems for a few years. My old IS300 had the same behaviour you describe from your GS. 

My wife’s Toyota Aygo with the X-Touch system (from 2014) has no such issues. Quick and responsive and always plays files in the correct order. Ironic on a car that’s a quarter of the price of a good NX/ES.  Aygo for the last year have also had apple CarPlay 😳

Lexus make great cars but I’ve often found their infotainment systems really poor. I’ve already started looking at other brands although I’m not to change for at least another 18 months. 

Link to comment
Share on other sites

  • 1 year later...

Hi All,

I'm new to this forum and this is my first post.  Sorry to tag onto an old thread.  Just got an RX and have come across this issue.  Previously I had always used the drivesort trick but this no longer works in the newer cars it seems.  I have raised this with my dealer and also directly with Lexus.  I would like to ask anyone who is annoyed by this and who has not raised a formal complaint to do so.  This may make Lexus push this bug up the priority list.  

I reported the bug here:

https://www.lexus.co.uk/forms/customer-relations-contact-us?enquiry_type=mm_nav

Paul

Link to comment
Share on other sites

  • 3 weeks later...

  • 4 weeks later...

Adrian, do the voice commands work for you on your UX, for things like, e.g. "Play Album <album name>"?  I ask because I have issues with this on my new RX.

Paul

Link to comment
Share on other sites

Hello PDM. Apologies for late reply. Heard nothing back from Lexus but then I didn't expect to. TBH not bothered with track play sequence nor voice command so will stick with things as they are.

Link to comment
Share on other sites

Thanks, Adrian.  Try not to judge me on my my taste in music....  I listen to a lot of film soundtracks/opera/musicals and these dont really work if played out of order.

Cheers and have a good weekend.

Paul

Link to comment
Share on other sites

  • 2 weeks later...

Hi Andrew,

I don't believe so.  When apple car play or android auto is enabled (on one usb port), the other usb port is disabled.  It's annoying.  I guess the system hardware was designed before apple car play was in existence and the MM19 system software may thus be limited by the underlying hardware for this.  (you could never play music from 2 usbs at once, hence the system never need to access both ports simultaneously before android auto/car play came along.)

Paul

Link to comment
Share on other sites

  • 6 months later...

Hi All,

I have just purchased a 2020 ES300h and part exchanged my 2016 Lexus RC200T and have to say - I think I've made a mistake...

So many niggles with the ES ...

Map shows speed camera's but there is no 'beep' - Lexus tell me to enable the 'beep' in settings but there is no option to do that. They could have enabled a pop up of the camera in the drivers dash as an alternative, especially as there are so many other pop ups such as 'close window' yes/no etc. I know the window is open as I'm sitting right next to it lol.

USB Memory stick - songs play TITLE alphabetically - Lexus reply - 'I have been in contact with our Technical Team regarding the USB music playback and it appears to be a limitation in the multimedia system. The workaround is to edit the audio file name to include the numbers which should play the album in the correct order.'

Album Art - I have added Album Art using mp3tag to around 6,000 tracks (took me ages) - image shows on some albums but not on others. They are all formatted the same on the PC.

In the RC200T, I could press and hold the right arrow key on the steering wheel and skip to next album. In the ES, it advances the track. There is no 'next album' option other than searching using the trackpad. Dangerous whilst driving.

Voice commands to play an artist just comes back with 'no source selected' (I am in the USB Media page playing songs from the memory stick) or 'cannot find, please say again' (that creates a loop).

Why does the passenger seat warm up on auto when there is no one sitting in it. Small point I know but it wastes electric 🙂 Lexus could easily fix this as the seatbelt warning only alerts when there is a passenger.

There are many other niggles so I won't go on.

Is there anyone out there as frustrated as I am and how do we get Lexus to actually listen and act upon customer satisfaction?

I'll get off the orange box now 🙂 

Neil

Link to comment
Share on other sites

3 minutes ago, NeilC said:

Hi All,

I have just purchased a 2020 ES300h and part exchanged my 2016 Lexus RC200T and have to say - I think I've made a mistake...

So many niggles with the ES ...

Map shows speed camera's but there is no 'beep' - Lexus tell me to enable the 'beep' in settings but there is no option to do that. They could have enabled a pop up of the camera in the drivers dash as an alternative, especially as there are so many other pop ups such as 'close window' yes/no etc. I know the window is open as I'm sitting right next to it lol.

USB Memory stick - songs play TITLE alphabetically - Lexus reply - 'I have been in contact with our Technical Team regarding the USB music playback and it appears to be a limitation in the multimedia system. The workaround is to edit the audio file name to include the numbers which should play the album in the correct order.'

Album Art - I have added Album Art using mp3tag to around 6,000 tracks (took me ages) - image shows on some albums but not on others. They are all formatted the same on the PC.

In the RC200T, I could press and hold the right arrow key on the steering wheel and skip to next album. In the ES, it advances the track. There is no 'next album' option other than searching using the trackpad. Dangerous whilst driving.

Voice commands to play an artist just comes back with 'no source selected' (I am in the USB Media page playing songs from the memory stick) or 'cannot find, please say again' (that creates a loop).

Why does the passenger seat warm up on auto when there is no one sitting in it. Small point I know but it wastes electric 🙂 Lexus could easily fix this as the seatbelt warning only alerts when there is a passenger.

There are many other niggles so I won't go on.

Is there anyone out there as frustrated as I am and how do we get Lexus to actually listen and act upon customer satisfaction?

I'll get off the orange box now 🙂 

Neil

Hi Neil,

Can I borrow your orange box for a moment?

I'm sorry you are also suffering with what is ultimately poorly tested software.  I came into my RX from a 2015 NX which probably had the same infotainment system as your 2016 RC.  I have also been very disappointed that functions that worked fine in a 2015 car are broken in a (more expensive) 2021 car.  In my opinion the MM19 infotainment system is still not release ready (even after several patches), let alone Lexus quality and, like you, I'm pretty upset about it.  Customer relations have been very helpful to me (as has my dealer) but it seems they do not have the backup of the relevant software engineering team in Toyota Motor Europe to get this fixed as things stand. They now prioritise bugs based on the numbers of complaints received.  I think you are the fifth person I know of here that has complained about these specific issues.  I have no idea how many complaints are the threshold to get things fixed but the more people who complain the more chance we have.  What happened to "The relentless pursuit of perfection"?

It looks like you have already found the main Easter eggs.  On the bright side, I think I can help you with some things, but some things we would need the source code to fix, which we don't have.

Firstly, can you let me know which NAV and AUDIO and nav_db versions of the software you are running?  (in settings -> general -> software update)

Let's start with the speed camera beep.  My feeling is that you have done an over the air update of map data (or the dealer/previous owner has) before handing over the car.  You can check this by looking at the nav_db version and comparing to setup->online->lexus online-> map update->current map version.  If the nav_db version is older than listed for some of the maps in Lexus online, then an OTA update has been done and this is known to break speed camera notifications.  If this is indeed the case, you need to reload the complete map database from usb stick.  It takes about 70mins and will refresh all the maps (not just UK which are probably the only ones you are updating if you do an OTA update).  I recommend not using OTA update:  it's currently broken and has been for at least the last 2 map updates.  You can get info on how to update from usb stick here by Phil (pobrown):

 

Now, to your other points.  These are less easy to fix.  Playing music alphabetically is utterly ridiculous and I simply don't understand how in 2021 we can have a Mark Levinson system in a Lexus that plays music in alphabetical order and not track order.  You literally can't make this stuff up.  And... a 2015/2016 car would be fine if you used drive sort (because it played in FAT order in the folder).  You have no choice at present with MM19 but to label all songs as you have suggested:

${discnumber}.${tracknumber} ${track name}

This will, however, make voice recognition of songs less reliable unless you can remember the track number of each song on each album.  (Of course voice commands are broken anyway.. more on that later).

Album art I *can* help you with.  I use mp3tag for modifying the mp3 id3 tag text fields, but not the album art images.  I use bliss for that and it has worked perfectly on all my tracks.  I would suggest that you may be running into the maximum limit of album art pixels or image file size (this is undocumented).  In bliss (not sure about mp3tag) you can force a maximum image size to 500x500 pixels.  These all work fine.  All my mp3s have embedded 500x500 jpeg and all work in the car.  Try modifying one that is not working to be a 500x500 pixel jpeg.

The big one for me if the broken voice commands.  All I can tell you is that there is a recognised error (by several people on here, several dealers and under some investigation by Lexus, but with insufficient complaints to prioritise a fix) with usb sticks of mp3s not being indexed into the voice command system.  On a 2015/16 vehicle, this works perfectly, every time (also on our old 2013 CT).  On MM19 it may kick off the indexing process at some point... perhaps in a week or so (I'm serious).  you may find at some point you start the car and voice commands work.  Or you may not.... this one requires patience.  Once it is indexed, it may stay working.  Or it may not....  Cross your fingers.  One thing is certain: if it is working and you remove the stick to add more music, it will be broken again.  the fact that this got through to release tells me that their trusting is at best insufficient. 

I hadn't noticed the different behaviour of track versus album advance.  I (would like to!) use voice commands to select and album.... 😞

For the heated seat on the passenger side when there is no one in the seat... on my RX it is the passenger door opening that causes the passenger side heating to enable.  Otherwise the passenger temperature dial is blank and the heated seat does not auto turn on.  I think there may be some setting in the menu that can enable that for you, but I know the climate settings on the new ES are different from the RX so an ES owner may be better placed to help here.

Sorry for the long rant.  I have been a Lexus customer for almost 10 years and to start with simply could not believe that these bugs existed.  I spent weeks wondering what I was doing wrong.  It simply never entered my mind that there would be so many bugs on a new Lexus.

OK, you can have your box back now!

Paul

 

P.S. I'll direct message you.

 

  • Like 2
Link to comment
Share on other sites

  • 1 year later...

Well guys I am having the same problem with my 2021 NX Takumi. When playing music from the USB I'm getting the same problem. I've tried adding track numbers first where they weren't shown but this does not seem to solve the issue. I see that you mention editing tag numbers but I'm not sure how to do this, any help would be appreciated. Screen shot of what my lexus is playing. Then tracklist as seen on Mac screen, plus info for track 1 as per USB stick. Hope all this makes some sense. TIA Mike

Screenshot 2023-04-13 at 12.22.17.jpg

Screenshot 2023-04-13 at 12.23.51.jpg

IMG_4621D.JPG

Link to comment
Share on other sites

9 minutes ago, Mike100C said:

Well guys I am having the same problem with my 2021 NX Takumi. When playing music from the USB I'm getting the same problem. I've tried adding track numbers first where they weren't shown but this does not seem to solve the issue. I see that you mention editing tag numbers but I'm not sure how to do this, any help would be appreciated. Screen shot of what my lexus is playing. Then tracklist as seen on Mac screen, plus info for track 1 as per USB stick. Hope all this makes some sense. TIA Mike

Screenshot 2023-04-13 at 12.22.17.jpg

Screenshot 2023-04-13 at 12.23.51.jpg

IMG_4621D.JPG

Mike,

Albums are played in ID3 Title alphabetical order.   It looks to me you have changed the file names and prefixed those with track numbers. This is fine, and how things used to work on older systems, but I guess you have MM19 on your NX.  This uses the ID3 tags of the files rather than the actual file names, so you need to edit the Title field of the ID3 tag in the same way.

These are additional pieces of data embedded in each file which includes things like title, track number, ***** number (for a multi CD album), artist etc.  On windows I edit this data with this package:

https://www.mp3tag.de/en/

It seems to have a Mac version too.

Paul

Link to comment
Share on other sites

Hi Paul, installed as recommended. I've attached a copy of my first imported album from apple music. This album is all over the place when played on my Lexus, but the screen here shows the correct order? What am I missing, what or even how do I edit? Sorry to be such a numpty!

 

Mike

Screenshot 2023-04-13 at 15.03.25.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...